summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-22 21:08:31 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-22 21:08:31 -0500
commit4f8306eba2f75cb573153b1280a9d8c9bf890135 (patch)
treebbd4c661350b95194ef52d396eb71f39ca10b8f5 /x11-libs/fltk
parentdev-libs/libatasmart: arm64 stable (bug #700526) (diff)
downloadgentoo-4f8306eba2f75cb573153b1280a9d8c9bf890135.tar.gz
gentoo-4f8306eba2f75cb573153b1280a9d8c9bf890135.tar.bz2
gentoo-4f8306eba2f75cb573153b1280a9d8c9bf890135.zip
x11-libs/fltk: fix BadInsIntoDir QA issue
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/fltk-1.3.3-r3.ebuild6
-rw-r--r--x11-libs/fltk/fltk-1.3.4.ebuild5
-rw-r--r--x11-libs/fltk/fltk-1.3.5-r4.ebuild5
-rw-r--r--x11-libs/fltk/fltk-1.3.9999.ebuild5
-rw-r--r--x11-libs/fltk/fltk-1.4.9999.ebuild5
5 files changed, 16 insertions, 10 deletions
diff --git a/x11-libs/fltk/fltk-1.3.3-r3.ebuild b/x11-libs/fltk/fltk-1.3.3-r3.ebuild
index 74e6007fed11..01db48d25b2c 100644
--- a/x11-libs/fltk/fltk-1.3.3-r3.ebuild
+++ b/x11-libs/fltk/fltk-1.3.3-r3.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
inherit autotools eutils fdo-mime flag-o-matic
DESCRIPTION="C++ user interface toolkit for X and OpenGL"
@@ -112,6 +113,7 @@ src_install() {
emake -C fluid \
DESTDIR="${D}" install-linux
+
if use doc; then
emake -C documentation \
DESTDIR="${D}" install
@@ -134,8 +136,8 @@ src_install() {
dodoc CHANGES README CREDITS ANNOUNCEMENT
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins test/*.{h,cxx,fl} test/demo.menu
+ docinto examples
+ dodoc -r test/*.{h,cxx,fl} test/demo.menu
fi
insinto /usr/share/cmake/Modules
diff --git a/x11-libs/fltk/fltk-1.3.4.ebuild b/x11-libs/fltk/fltk-1.3.4.ebuild
index b1dbc2b941e3..a390fa4097e4 100644
--- a/x11-libs/fltk/fltk-1.3.4.ebuild
+++ b/x11-libs/fltk/fltk-1.3.4.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit autotools fdo-mime flag-o-matic multilib-minimal
DESCRIPTION="C++ user interface toolkit for X and OpenGL"
@@ -157,8 +158,8 @@ multilib_src_install_all() {
done
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins test/*.{h,cxx,fl} test/demo.menu
+ docinto examples
+ dodoc -r test/*.{h,cxx,fl} test/demo.menu
fi
insinto /usr/share/cmake/Modules
diff --git a/x11-libs/fltk/fltk-1.3.5-r4.ebuild b/x11-libs/fltk/fltk-1.3.5-r4.ebuild
index 7af2106929bc..30f91c3198fd 100644
--- a/x11-libs/fltk/fltk-1.3.5-r4.ebuild
+++ b/x11-libs/fltk/fltk-1.3.5-r4.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools flag-o-matic xdg-utils multilib-minimal
DESCRIPTION="C++ user interface toolkit for X and OpenGL"
@@ -162,8 +163,8 @@ multilib_src_install_all() {
done
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins test/*.{h,cxx,fl} test/demo.menu
+ docinto examples
+ dodoc -r test/*.{h,cxx,fl} test/demo.menu
fi
insinto /usr/share/cmake/Modules
diff --git a/x11-libs/fltk/fltk-1.3.9999.ebuild b/x11-libs/fltk/fltk-1.3.9999.ebuild
index f8b095c4b45d..de2c6eb095ec 100644
--- a/x11-libs/fltk/fltk-1.3.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.3.9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools flag-o-matic git-r3 xdg-utils multilib-minimal
DESCRIPTION="C++ user interface toolkit for X and OpenGL"
@@ -170,8 +171,8 @@ multilib_src_install_all() {
done
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins test/*.{h,cxx,fl} test/demo.menu
+ docinto examples
+ dodoc -r test/*.{h,cxx,fl} test/demo.menu
fi
insinto /usr/share/cmake/Modules
diff --git a/x11-libs/fltk/fltk-1.4.9999.ebuild b/x11-libs/fltk/fltk-1.4.9999.ebuild
index 7940dc7b3efe..4ab26198da79 100644
--- a/x11-libs/fltk/fltk-1.4.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.4.9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools flag-o-matic git-r3 xdg-utils multilib-minimal
DESCRIPTION="C++ user interface toolkit for X and OpenGL"
@@ -174,8 +175,8 @@ multilib_src_install_all() {
done
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins test/*.{h,cxx,fl} test/demo.menu
+ docinto examples
+ dodoc -r test/*.{h,cxx,fl} test/demo.menu
fi
insinto /usr/share/cmake/Modules