summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Kittner <andy.kittner@gmail.com>2016-08-12 22:45:12 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-27 16:05:45 +0200
commit546c66647a2c926ed94c72582e1eb7c640f4eaa8 (patch)
tree77e7d05faa94c272fe52e41f717eccd71168d1a0 /x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild
parentsys-kernel/rt-sources: version bump to {3.14.75_p80,3.18.39_p41,4.1.30_p34,4.... (diff)
downloadgentoo-546c66647a2c926ed94c72582e1eb7c640f4eaa8.tar.gz
gentoo-546c66647a2c926ed94c72582e1eb7c640f4eaa8.tar.bz2
gentoo-546c66647a2c926ed94c72582e1eb7c640f4eaa8.zip
x11-libs/gdk-pixbuf-loader-webp: new package.
A format plugin for gdk-pixbuf that allows GTK applications (e.g media-gfx/geeqie) to read webp images. Gentoo-Bug: https://bugs.gentoo.org/575030 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2076 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild')
-rw-r--r--x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild b/x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild
new file mode 100644
index 000000000000..420386797be0
--- /dev/null
+++ b/x11-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-20160328234507.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/aruiz/webp-pixbuf-loader"
+EGIT_COMMIT=9b92950d49d7939f90ba7413deb7ec6b392b2054
+
+inherit git-r3 cmake-multilib gnome2-utils
+
+DESCRIPTION="WebP Image format GdkPixbuf loader"
+HOMEPAGE="https://github.com/aruiz/webp-pixbuf-loader"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=media-libs/libwebp-0.4.3
+ >=x11-libs/gdk-pixbuf-2.22"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=( -DINSTALL_LIB_DIR:PATH=$(get_libdir) )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_gdk_pixbuf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}
+
+pkg_postinst() {
+ gnome2_gdk_pixbuf_update
+}