summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-25 16:17:48 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-25 16:17:48 +0100
commit69022995c5a800d9ecd551900a7cd6db22c8236a (patch)
tree141fdf11b15a5b2908990598440b5d924dc6f925 /x11-libs/gl2ps
parentsys-apps/debianutils: Removed old. (diff)
downloadgentoo-69022995c5a800d9ecd551900a7cd6db22c8236a.tar.gz
gentoo-69022995c5a800d9ecd551900a7cd6db22c8236a.tar.bz2
gentoo-69022995c5a800d9ecd551900a7cd6db22c8236a.zip
x11-libs/gl2ps: Bump to version 1.3.9
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-libs/gl2ps')
-rw-r--r--x11-libs/gl2ps/Manifest1
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch4
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.9.ebuild54
3 files changed, 57 insertions, 2 deletions
diff --git a/x11-libs/gl2ps/Manifest b/x11-libs/gl2ps/Manifest
index 3ee7d60777cb..2e3de1013637 100644
--- a/x11-libs/gl2ps/Manifest
+++ b/x11-libs/gl2ps/Manifest
@@ -1 +1,2 @@
DIST gl2ps-1.3.8.tgz 296245 SHA256 2fe58dd95df06688a8c188e70b1803093ebf0797954901f4a36a403dbc301ee5 SHA512 76e90d675764196d249d87c6041088736a8b41d9b93620c6171a40362a259d50e34d5efc06e4ea17e6c147bc26b6a3a7356d95ea5e204193ef631fb48e0c0a4e WHIRLPOOL 85d93e744824f1681f562f791e07411cb5d815575847466a235e9952f2061c970cbf546e0dc6c5ed36f0261943814ce1a978f497f58b29b2a527245ad856b90b
+DIST gl2ps-1.3.9.tgz 294907 SHA256 8a680bff120df8bcd78afac276cdc38041fed617f2721bade01213362bcc3640 SHA512 e6770c27d4832a300b4e16a9f98deb8557e7875460e7aa7e655fdb796f5dfffd5eccdc8b15f5a3ae151713fc46f97dacad48ee7550c41373b6fc8cfd21a437cb WHIRLPOOL 2ba0611daa39814a02c97ceec70c2e36b46881371a6a4790c5f5db4ea7e8b3352a25228d3aab60d2ec5b6f9e5070d9a7f331ebed2df355a6444f4e20365d7915
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch b/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch
index 5382b5b3ae73..f22760fd6eca 100644
--- a/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch
@@ -6,8 +6,8 @@ Patch to add various enhancements to cmake:
* optional examples building
* do not install static libraries
---- CMakeLists.txt 2012-09-02 02:07:33.000000000 -0700
-+++ CMakeLists.txt 2012-09-17 13:51:58.337832078 -0700
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -46,6 +46,8 @@
option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
diff --git a/x11-libs/gl2ps/gl2ps-1.3.9.ebuild b/x11-libs/gl2ps/gl2ps-1.3.9.ebuild
new file mode 100644
index 000000000000..ac5f65d23683
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils multilib
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+RDEPEND="
+ media-libs/freeglut
+ x11-libs/libXmu
+ png? ( media-libs/libpng:0= )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended )"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3.8-cmake.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed '/^install.*TODO\.txt/d' -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DUSE_ENABLE_DOC="$(usex doc)"
+ -DUSE_ENABLE_PNG="$(usex png)"
+ -DUSE_ENABLE_ZLIB="$(usex zlib)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}