summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild')
-rw-r--r--x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild
new file mode 100644
index 000000000000..890ad6f4c9eb
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_ORG_MODULE="vte"
+
+inherit gnome2
+
+DESCRIPTION="GNOME Setuid helper for opening ptys"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+# gnome-pty-helper is inside vte
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+hardened"
+
+# gnome-pty-helper was spit out with 0.27.90
+RDEPEND="!<x11-libs/vte-0.27.90"
+DEPEND=""
+
+S="${WORKDIR}/vte-${PV}/gnome-pty-helper"
+
+src_prepare() {
+ # As recommended by upstream (/usr/libexec/$PN is a setgid binary)
+ if use hardened; then
+ export SUID_CFLAGS="-fPIE ${SUID_CFLAGS}"
+ export SUID_LDFLAGS="-pie ${SUID_LDFLAGS}"
+ fi
+ gnome2_src_prepare
+}