summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-05-10 12:44:54 +0300
committerMart Raudsepp <leio@gentoo.org>2018-05-10 13:06:26 +0300
commit2b8e2704135d28a52fdd994f66afbb6c4846576f (patch)
tree36225cbba51b1c196da33f566c4d7029282126dc /x11-libs/goffice/goffice-0.10.41.ebuild
parentnet-libs/telepathy-logger-qt: remove unused patch(es) (diff)
downloadgentoo-2b8e2704135d28a52fdd994f66afbb6c4846576f.tar.gz
gentoo-2b8e2704135d28a52fdd994f66afbb6c4846576f.tar.bz2
gentoo-2b8e2704135d28a52fdd994f66afbb6c4846576f.zip
x11-libs/goffice: bump to 0.10.41
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'x11-libs/goffice/goffice-0.10.41.ebuild')
-rw-r--r--x11-libs/goffice/goffice-0.10.41.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/goffice/goffice-0.10.41.ebuild b/x11-libs/goffice/goffice-0.10.41.ebuild
new file mode 100644
index 000000000000..9bf3bf394d80
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.41.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}