summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-08 19:31:01 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-08 20:22:59 +0200
commitd3e4dcd717dbaee4bb20634df3ec01e5c3650f1b (patch)
tree5f03cc8513d11936ec690618952de65f43aa9eb5 /x11-libs/gtk+/files
parentx11-themes/gnome-themes-standard: split theme engine out (diff)
downloadgentoo-d3e4dcd717dbaee4bb20634df3ec01e5c3650f1b.tar.gz
gentoo-d3e4dcd717dbaee4bb20634df3ec01e5c3650f1b.tar.bz2
gentoo-d3e4dcd717dbaee4bb20634df3ec01e5c3650f1b.zip
x11-libs/gtk+: version bump from 2.24.31 to 2.24.31-r1
Switch to EAPI6. Drop deprecated comment on cairo[svg]. Fix man pages automagic. Remove man page that belongs to other packages. Add missing get_exeext handling. Depend on adwaita icon theme, adwaita theme engine and adwaita and highconstrast themes to fix inconsistent default settings set by the ebuild. Gentoo-bug: 569552 Package-Manager: portage-2.3.1
Diffstat (limited to 'x11-libs/gtk+/files')
-rw-r--r--x11-libs/gtk+/files/gtk+-2.24.31-fix-gtkentry-beep.patch42
-rw-r--r--x11-libs/gtk+/files/gtk+-2.24.31-update-icon-cache.patch78
2 files changed, 120 insertions, 0 deletions
diff --git a/x11-libs/gtk+/files/gtk+-2.24.31-fix-gtkentry-beep.patch b/x11-libs/gtk+/files/gtk+-2.24.31-fix-gtkentry-beep.patch
new file mode 100644
index 000000000000..1d09721b6711
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.24.31-fix-gtkentry-beep.patch
@@ -0,0 +1,42 @@
+From debba4d14155a9e5736de069c2b693ab6f6e21aa Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Wed, 5 Oct 2016 12:20:14 -0400
+Subject: [PATCH] entry: Fix a corner case of overwrite mode
+
+We currently beep when a character is appended at the end in
+overwrite mode. That is obviously not right. Patch based on
+a patch by Ian MacDonald.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=772389
+---
+ gtk/gtkentry.c | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/gtk/gtkentry.c b/gtk/gtkentry.c
+index b522039..bc33754 100644
+--- a/gtk/gtkentry.c
++++ b/gtk/gtkentry.c
+@@ -5224,6 +5224,7 @@ gtk_entry_enter_text (GtkEntry *entry,
+ GtkEditable *editable = GTK_EDITABLE (entry);
+ gint tmp_pos;
+ gboolean old_need_im_reset;
++ guint text_length;
+
+ old_need_im_reset = entry->need_im_reset;
+ entry->need_im_reset = FALSE;
+@@ -5233,7 +5234,11 @@ gtk_entry_enter_text (GtkEntry *entry,
+ else
+ {
+ if (entry->overwrite_mode)
+- gtk_entry_delete_from_cursor (entry, GTK_DELETE_CHARS, 1);
++ {
++ text_length = gtk_entry_buffer_get_length (get_buffer (entry));
++ if (entry->current_pos < text_length)
++ gtk_entry_delete_from_cursor (entry, GTK_DELETE_CHARS, 1);
++ }
+ }
+
+ tmp_pos = entry->current_pos;
+--
+2.10.0
+
diff --git a/x11-libs/gtk+/files/gtk+-2.24.31-update-icon-cache.patch b/x11-libs/gtk+/files/gtk+-2.24.31-update-icon-cache.patch
new file mode 100644
index 000000000000..11dbb5e4a705
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.24.31-update-icon-cache.patch
@@ -0,0 +1,78 @@
+From 260f94f3914ba18a256e6f1c222f643a57854e80 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 9 May 2015 23:30:58 +0200
+Subject: [PATCH] Always use external gtk-update-icon-cache
+
+---
+ configure.ac | 8 +++-----
+ docs/reference/gtk/Makefile.am | 2 +-
+ gtk/Makefile.am | 13 ++-----------
+ 3 files changed, 6 insertions(+), 17 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4e11b40..7ef8cb6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -913,11 +913,9 @@ dnl Look for a host system's gdk-pixbuf-csource if we are cross-compiling
+
+ AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
+
+-if test $cross_compiling = yes; then
+- AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
+- if test x$GTK_UPDATE_ICON_CACHE = xno; then
+- REBUILD_PNGS=#
+- fi
++AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
++if test x$GTK_UPDATE_ICON_CACHE = xno; then
++ REBUILD_PNGS=#
+ fi
+
+ AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource, no)
+diff --git a/docs/reference/gtk/Makefile.am b/docs/reference/gtk/Makefile.am
+index c239445..60b5265 100644
+--- a/docs/reference/gtk/Makefile.am
++++ b/docs/reference/gtk/Makefile.am
+@@ -368,7 +368,7 @@ EXTRA_DIST += version.xml.in
+
+ if ENABLE_MAN
+
+-man_MANS = gtk-query-immodules-2.0.1 gtk-update-icon-cache.1 gtk-builder-convert.1
++man_MANS = gtk-query-immodules-2.0.1 gtk-builder-convert.1
+
+ %.1 : %.xml
+ @XSLTPROC@ -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+diff --git a/gtk/Makefile.am b/gtk/Makefile.am
+index 8cc4536..a7afbf3 100644
+--- a/gtk/Makefile.am
++++ b/gtk/Makefile.am
+@@ -1087,8 +1087,7 @@ endif
+ # Installed tools
+ #
+ bin_PROGRAMS = \
+- gtk-query-immodules-2.0 \
+- gtk-update-icon-cache
++ gtk-query-immodules-2.0
+
+ bin_SCRIPTS = gtk-builder-convert
+
+@@ -1438,16 +1437,8 @@ stamp-icons: $(STOCK_ICONS)
+ ) done \
+ && touch stamp-icons
+
+-if CROSS_COMPILING
+-gtk_update_icon_cache_program = $(GTK_UPDATE_ICON_CACHE)
+-else
+-gtk_update_icon_cache_program = \
+- ./gtk-update-icon-cache
+-endif
+-
+ gtkbuiltincache.h: @REBUILD@ stamp-icons
+- $(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT)
+- $(gtk_update_icon_cache_program) --force --ignore-theme-index \
++ $(GTK_UPDATE_ICON_CACHE) --force --ignore-theme-index \
+ --include-image-data \
+ --source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
+ mv gtkbuiltincache.h.tmp gtkbuiltincache.h
+--
+2.10.0
+