summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-24 21:16:41 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-24 21:38:26 -0700
commite0a2c72eaefb5d8da91bdf6af9662fc39abb939c (patch)
tree834a5da96634d1010052056971734526c82ed8ae /x11-libs/gtk+extra
parentnet-libs/kdsoap-ws-discovery-client: keyword on ~ppc64, bug #489446 (diff)
downloadgentoo-e0a2c72eaefb5d8da91bdf6af9662fc39abb939c.tar.gz
gentoo-e0a2c72eaefb5d8da91bdf6af9662fc39abb939c.tar.bz2
gentoo-e0a2c72eaefb5d8da91bdf6af9662fc39abb939c.zip
x11-libs/gtk+extra: Version bump to 3.3.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/gtk+extra')
-rw-r--r--x11-libs/gtk+extra/Manifest1
-rw-r--r--x11-libs/gtk+extra/gtk+extra-3.3.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/gtk+extra/Manifest b/x11-libs/gtk+extra/Manifest
index 1f1d6d4c1485..80e7f9ec45cd 100644
--- a/x11-libs/gtk+extra/Manifest
+++ b/x11-libs/gtk+extra/Manifest
@@ -1 +1,2 @@
DIST gtkextra-3.3.3.tar.gz 1503817 BLAKE2B dc99923ad962348d617b8db2171b99e925d0dc06501110d805f166ba25cff72094c02031e3375304ddfd96cc7d3f76a1b06d56b196aec1d1868f10d154acfc8e SHA512 864fa2e957941a05a9c4b4a4283ae48e733d72ab334e2fb8440fc884166b0d1ad34d381924184f7a88f829d00bbd857d5f3f32d89f159e0133dd89233a8a93e9
+DIST gtkextra-3.3.4.tar.gz 1542795 BLAKE2B 5a6d5b72f34c8373db615961728a01d0c27005726f316c1233b0b4c4dba688022a53236cc3abe090891a53441d910322ea938ea864a13933a5cea87f18e3426b SHA512 fd61bce7070cf4f28129b47a6c0b01e974101d96b525be9ce1bc4b40ce94197f3c411d17fd8954f5549075c4cdd7ac58a6aaa6faa2f5d3013b761391559e570b
diff --git a/x11-libs/gtk+extra/gtk+extra-3.3.4.ebuild b/x11-libs/gtk+extra/gtk+extra-3.3.4.ebuild
new file mode 100644
index 000000000000..03058820a695
--- /dev/null
+++ b/x11-libs/gtk+extra/gtk+extra-3.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Useful Additional GTK+ widgets"
+HOMEPAGE="http://gtkextra.sourceforge.net"
+SRC_URI="mirror://sourceforge/gtkextra/gtkextra-${PV}.tar.gz"
+
+LICENSE="FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.12.0:2
+ dev-libs/glib:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+# dev-libs/gobject-introspection-common needed for eautoreconf
+
+S="${WORKDIR}/gtkextra-${PV}"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-glade=no \
+ --disable-man \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}