summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2016-06-27 23:38:32 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2016-06-27 23:46:50 -0400
commit79c35561dc5a0da36550838994c1d33d3afc0fcc (patch)
tree38fc036da1ef4be595484e1035015c3de8614d57 /x11-libs/gtksourceview/gtksourceview-3.20.4.ebuild
parentwww-client/chromium: beta channel bump (52.0.2743.49) (diff)
downloadgentoo-79c35561dc5a0da36550838994c1d33d3afc0fcc.tar.gz
gentoo-79c35561dc5a0da36550838994c1d33d3afc0fcc.tar.bz2
gentoo-79c35561dc5a0da36550838994c1d33d3afc0fcc.zip
x11-libs/gtksourceview: bump to 3.20.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-libs/gtksourceview/gtksourceview-3.20.4.ebuild')
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.20.4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/gtksourceview-3.20.4.ebuild b/x11-libs/gtksourceview/gtksourceview-3.20.4.ebuild
new file mode 100644
index 000000000000..c5aca10c2316
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.20.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.47:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.19.6:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ dev-util/itstool
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-providers \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}