summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-07 19:51:30 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-07 21:04:14 +0200
commitd81a539e51afea58227d5e686d00632b58da55a1 (patch)
tree899a90d72ee5669ac5ab1cc1bcd7fa80f42a9590 /x11-libs/gtksourceview
parentapp-dicts/gnome-dictionary: bump to 3.26.1 (diff)
downloadgentoo-d81a539e51afea58227d5e686d00632b58da55a1.tar.gz
gentoo-d81a539e51afea58227d5e686d00632b58da55a1.tar.bz2
gentoo-d81a539e51afea58227d5e686d00632b58da55a1.zip
x11-libs/gtksourceview: bump to 3.24.9
Remove unecessary itstool dep - configure checks for it, but it's non-fatal and nothing uses the resulting ITSTOOL build variable. Default enable USE=vala, because various things are starting to require it in a meson build world - already the case with gnome-calculator. Stop passing --disable-deprecations, as that actually adds G_DISABLE_DEPRECATED and so on, which we actually do NOT want to happen - but we ended up not having them anyways, as we sed the configure logic to not add them. So this instructs it to do the right thing, instead of relying on the eclass logic to force us doing the right thing. Bug: https://bugs.gentoo.org/665578 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/Manifest1
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.24.9.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index f14b7e102328..49933a55cf2a 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -1,2 +1,3 @@
DIST gtksourceview-2.10.5.tar.bz2 1253321 BLAKE2B 810a3eeca69bab4356b21c64129bb852e00d02c7937ad4a2ce3af9e48700da943d8d6834efcce9810dd49a54f39d4a074dc086a557128da51a593b2f23e58d48 SHA512 6f64acef6196bfc5953e0b148d7e460d366073b5e21367c01b01fc4d1c86ffe8aca71ecd77cf0814e47d8fc3085495f25bbbdc69e746987b02fd02fcda64886d
DIST gtksourceview-3.24.8.tar.xz 1408964 BLAKE2B e406aa9f776821abfcc87333fc955b4f3ae334f73a8b1dfa0b123067df24bd4f473e326347c99df7dc6c97adbdde8739cb301e45ca70324f6e8de2ce9e1ea973 SHA512 84a02278344f9fe3c1b8f2440c6179feaea53df93061c63023d92bcaa1ec7ff8e95e1f3a463c23d8487c74492469f3dc367bcca3975ef169bf03925ecee7f7ff
+DIST gtksourceview-3.24.9.tar.xz 1414444 BLAKE2B 9d148fba03339c7dccca70822f498aea6423125af1a954e0c9f8ff9735141fc9e4f845c7172be5faf97e694445dc95d41d5d903ef5b5da3dd0ce7fe58b524ca7 SHA512 29b58afba1c0b473205cf7070997139d2ca07cf68d40185aa76fa59c900ad21c03ccb79dec9970e5f96743cfdb5a7d926b21a9947244bc8cf8cbd1033467cd01
diff --git a/x11-libs/gtksourceview/gtksourceview-3.24.9.ebuild b/x11-libs/gtksourceview/gtksourceview-3.24.9.ebuild
new file mode 100644
index 000000000000..f1f99c3904a3
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.24.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+
+IUSE="glade +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.48:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}