summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-10 13:52:31 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-10 13:52:31 +0100
commit377d3d80573bdb60ce7e5aa01809f012ee9e233d (patch)
tree778aa0efbad92fbb225c4b684d7db7a667df46d3 /x11-libs/libGLw/libGLw-8.0.0-r1.ebuild
parentapp-text/texlive-core: Drop old (diff)
downloadgentoo-377d3d80573bdb60ce7e5aa01809f012ee9e233d.tar.gz
gentoo-377d3d80573bdb60ce7e5aa01809f012ee9e233d.tar.bz2
gentoo-377d3d80573bdb60ce7e5aa01809f012ee9e233d.zip
x11-libs/libGLw: Fix for -fno-common
Closes: https://bugs.gentoo.org/706600 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs/libGLw/libGLw-8.0.0-r1.ebuild')
-rw-r--r--x11-libs/libGLw/libGLw-8.0.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/libGLw/libGLw-8.0.0-r1.ebuild b/x11-libs/libGLw/libGLw-8.0.0-r1.ebuild
new file mode 100644
index 000000000000..202de4da9755
--- /dev/null
+++ b/x11-libs/libGLw/libGLw-8.0.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=glw-"${PV}"
+
+DESCRIPTION="Mesa GLw library"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/glw/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="+motif"
+
+RDEPEND="
+ !media-libs/mesa[motif]
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/motif:0
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc10-fno-common.patch )
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-motif
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}