summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-05-18 18:47:15 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-05-18 18:47:15 +0200
commitc67547773c3ff747213bf9c464273f1030ed27a8 (patch)
tree2b5b6ea77eeea9c97fdfecbe0576811c5a80c506 /x11-libs/libX11/libX11-1.7.1.ebuild
parentapp-backup/bacula: Version bump (diff)
downloadgentoo-c67547773c3ff747213bf9c464273f1030ed27a8.tar.gz
gentoo-c67547773c3ff747213bf9c464273f1030ed27a8.tar.bz2
gentoo-c67547773c3ff747213bf9c464273f1030ed27a8.zip
x11-libs/libX11: 1.7.1 version bump.
Bug: https://bugs.gentoo.org/790824 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'x11-libs/libX11/libX11-1.7.1.ebuild')
-rw-r--r--x11-libs/libX11/libX11-1.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/libX11/libX11-1.7.1.ebuild b/x11-libs/libX11/libX11-1.7.1.ebuild
new file mode 100644
index 000000000000..d2e7fcff0e6e
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit toolchain-funcs xorg-3
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ !<x11-base/xorg-proto-2019.2
+ x11-misc/compose-tables"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}