summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-06-18 22:03:51 -0700
committerMatt Turner <mattst88@gentoo.org>2018-06-18 22:07:53 -0700
commita1d998b88ecbd6726b574e5df711779c964f5769 (patch)
tree50dfb4d0f9775721841b5de15e1a0777caa0e3b6 /x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild
parentsys-cluster/neutron: 11.0.5 bup (diff)
downloadgentoo-a1d998b88ecbd6726b574e5df711779c964f5769.tar.gz
gentoo-a1d998b88ecbd6726b574e5df711779c964f5769.tar.bz2
gentoo-a1d998b88ecbd6726b574e5df711779c964f5769.zip
x11-libs/libXaw3d: Version bump 1.6.3
Also add xpm USE flag. Closes: https://bugs.gentoo.org/636766
Diffstat (limited to 'x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild')
-rw-r--r--x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild b/x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild
new file mode 100644
index 000000000000..b92be978bab7
--- /dev/null
+++ b/x11-libs/libXaw3d/libXaw3d-1.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="X.Org Xaw3d library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="unicode xpm"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable unicode internationalization)
+ $(use_enable xpm multiplane-bitmaps)
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+
+ xorg-2_pkg_setup
+}