summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-09-04 19:10:17 -0400
committerMatt Turner <mattst88@gentoo.org>2020-09-08 12:25:00 -0700
commit485886874f7b0599dd47cc7e94463e9b39c0e89e (patch)
treea6efc6303c85137dad03dec9426dc03faadf641d /x11-libs/libXaw
parentx11-libs/libSM: EAPI 7 (diff)
downloadgentoo-485886874f7b0599dd47cc7e94463e9b39c0e89e.tar.gz
gentoo-485886874f7b0599dd47cc7e94463e9b39c0e89e.tar.bz2
gentoo-485886874f7b0599dd47cc7e94463e9b39c0e89e.zip
x11-libs/libXaw: EAPI 7
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/libXaw-1.0.13-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/libXaw/libXaw-1.0.13-r2.ebuild b/x11-libs/libXaw/libXaw-1.0.13-r2.ebuild
new file mode 100644
index 000000000000..a7fcece439b2
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.13-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}