summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-18 05:02:25 +0000
committerSam James <sam@gentoo.org>2022-12-18 05:03:09 +0000
commit578ec8ac64277873e10168f2bbf4de43c29a79df (patch)
tree0aeaa2bffdaa6e0900e69fcb4d115dca862d3d81 /x11-libs/libXdmcp/libXdmcp-1.1.4-r2.ebuild
parentdev-libs/openssl: keyword 3.0.7-r2 for ~x86 (diff)
downloadgentoo-578ec8ac64277873e10168f2bbf4de43c29a79df.tar.gz
gentoo-578ec8ac64277873e10168f2bbf4de43c29a79df.tar.bz2
gentoo-578ec8ac64277873e10168f2bbf4de43c29a79df.zip
x11-libs/libXdmcp: libbsd is needed for non-glibc still
musl doesn't provide arc4random_buf (or getentropy). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/libXdmcp/libXdmcp-1.1.4-r2.ebuild')
-rw-r--r--x11-libs/libXdmcp/libXdmcp-1.1.4-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libXdmcp/libXdmcp-1.1.4-r2.ebuild b/x11-libs/libXdmcp/libXdmcp-1.1.4-r2.ebuild
new file mode 100644
index 000000000000..ef38544cc615
--- /dev/null
+++ b/x11-libs/libXdmcp/libXdmcp-1.1.4-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org X Display Manager Control Protocol library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+RDEPEND="
+ elibc_glibc? (
+ || ( >=sys-libs/glibc-2.36 dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ )
+ !elibc_glibc? (
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}