summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-01 20:55:09 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-01 21:10:17 -0700
commit51edd84c37bf6a34222e46ab15989464bbec05de (patch)
tree548b020e6dce1382e5453a533fd486f4894f9431 /x11-libs/libXfont2
parentx11-libs/libXfont2: Depend on dev-libs/libbsd (diff)
downloadgentoo-51edd84c37bf6a34222e46ab15989464bbec05de.tar.gz
gentoo-51edd84c37bf6a34222e46ab15989464bbec05de.tar.bz2
gentoo-51edd84c37bf6a34222e46ab15989464bbec05de.zip
x11-libs/libXfont2: Version bump to 2.0.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXfont2')
-rw-r--r--x11-libs/libXfont2/Manifest1
-rw-r--r--x11-libs/libXfont2/libXfont2-2.0.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/libXfont2/Manifest b/x11-libs/libXfont2/Manifest
index ea362bd0ceb4..06e37d3b3a8b 100644
--- a/x11-libs/libXfont2/Manifest
+++ b/x11-libs/libXfont2/Manifest
@@ -1 +1,2 @@
DIST libXfont2-2.0.4.tar.bz2 513167 BLAKE2B 924cf8462a8fc593755080866b63d6cca6e58b5d875f1d25b95271a56d883e983445f72f8950adf1964e0bf10ca5b8bb2ddfe0c56d4395086e460952a5933bd7 SHA512 7cf6c58e520e48e24fc4f05fec760fcbeaaac0cedeed57dded262c855e1515cc34cd033222945a0b016f6857b83009fc2a6946c7d632c2f7bb0060f8e8a8a106
+DIST libXfont2-2.0.5.tar.bz2 524868 BLAKE2B 0b26d4c93452bcb3f5c740ac8984b9873a8241405d270e2d3fa5f440be820db417c9eff59c7a1a8c175513e40df70ada9c037d45c3a9ae2ccf62eb12f81c1d8f SHA512 64d0635d14676bb645d61932afb177eb3808a46525b26e7ee31abc975eca75207743e85523fdd82b08010ce124eb4802338b508ee7b126875d2a3c12f8ac4faa
diff --git a/x11-libs/libXfont2/libXfont2-2.0.5.ebuild b/x11-libs/libXfont2/libXfont2-2.0.5.ebuild
new file mode 100644
index 000000000000..a07d98ab5832
--- /dev/null
+++ b/x11-libs/libXfont2/libXfont2-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_PACKAGE_NAME=libxfont
+XORG_DOC=doc
+inherit xorg-3
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 ipv6 truetype"
+
+RDEPEND="sys-libs/zlib
+ dev-libs/libbsd
+ x11-libs/libfontenc
+ bzip2? ( app-arch/bzip2 )
+ truetype? ( >=media-libs/freetype-2 )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc devel-docs)
+ $(use_with doc xmlto)
+ $(use_with bzip2)
+ $(use_enable truetype freetype)
+ --without-fop
+ )
+ xorg-3_src_configure
+}