summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-17 18:44:34 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-17 18:56:04 -0400
commitbd9f2e18bd96e125a6a3ca2b7e3eafe794920604 (patch)
tree7dec3e26ec87da9b2cbf96d4b6c476e299827af7 /x11-libs/libXmu
parentsys-apps/dcfldd: 1.8 + EAPI 8 (diff)
downloadgentoo-bd9f2e18bd96e125a6a3ca2b7e3eafe794920604.tar.gz
gentoo-bd9f2e18bd96e125a6a3ca2b7e3eafe794920604.tar.bz2
gentoo-bd9f2e18bd96e125a6a3ca2b7e3eafe794920604.zip
x11-libs/libXmu: Version bump to 1.1.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXmu')
-rw-r--r--x11-libs/libXmu/Manifest1
-rw-r--r--x11-libs/libXmu/libXmu-1.1.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/libXmu/Manifest b/x11-libs/libXmu/Manifest
index cdb58846ef44..4be46b752816 100644
--- a/x11-libs/libXmu/Manifest
+++ b/x11-libs/libXmu/Manifest
@@ -1 +1,2 @@
DIST libXmu-1.1.3.tar.bz2 394330 BLAKE2B 5bbc4345f32588a8b1e196fef39a636b9a765a2d22a12cc30bc7f5528b004c1f73370d25b023b68772081f1c58b4813293971f8f08ca8f2b9508adb4c3925c94 SHA512 8c6cc65b22aa031ad870dd92736681a068a0878a425a53dbed909943da1136c4a24034d467cfd3785c3a8d78f66850b69f1ebe1eb24aaf9bc176b1d171a5c762
+DIST libXmu-1.1.4.tar.xz 349264 BLAKE2B fe78cd3f529402394c19842b31b2451da2b16dc768b5aac1d157feea0af06b04dbe2be879d17c7ccff08630c0bdab0abbb853bc5672340f55da0cd1412db9df6 SHA512 3cf90cb3ff380aafefbb39297bdd95b9e1e6d6618cecb53ff09faf38f9b9c54599d28367f07a9ec77a20214c6c3e661b8d0a12b38082556790a79a59942039c1
diff --git a/x11-libs/libXmu/libXmu-1.1.4.ebuild b/x11-libs/libXmu/libXmu-1.1.4.ebuild
new file mode 100644
index 000000000000..5b4b3ad145ec
--- /dev/null
+++ b/x11-libs/libXmu/libXmu-1.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xmu library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}