summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-05-21 20:44:13 +0200
committerMatt Turner <mattst88@gentoo.org>2018-05-21 18:05:11 -0700
commit83dc01303b443fe40a543c28f64ff5eca6396b51 (patch)
treed18207f1b06d91931733728b57b77fb77c34e713 /x11-libs/libXpm/libXpm-3.5.12-r1.ebuild
parentx11-libs/libfontenc: Update x11-proto/xproto dependency to x11-base/xorg-prot... (diff)
downloadgentoo-83dc01303b443fe40a543c28f64ff5eca6396b51.tar.gz
gentoo-83dc01303b443fe40a543c28f64ff5eca6396b51.tar.bz2
gentoo-83dc01303b443fe40a543c28f64ff5eca6396b51.zip
x11-libs/libXpm: Update x11-proto/* dependencies to x11-base/xorg-proto and drop it from RDEPEND.
Diffstat (limited to 'x11-libs/libXpm/libXpm-3.5.12-r1.ebuild')
-rw-r--r--x11-libs/libXpm/libXpm-3.5.12-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/libXpm/libXpm-3.5.12-r1.ebuild b/x11-libs/libXpm/libXpm-3.5.12-r1.ebuild
new file mode 100644
index 000000000000..265319ee68ef
--- /dev/null
+++ b/x11-libs/libXpm/libXpm-3.5.12-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xpm library"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ x11-base/xorg-proto"
+
+src_configure() {
+ # the gettext configure check and code in sxpm are incorrect; they assume
+ # gettext being in libintl, whereas Solaris has gettext by default
+ # resulting in libintl not being added to LIBS
+ [[ ${CHOST} == *-solaris* ]] && export ac_cv_search_gettext=-lintl
+ xorg-2_src_configure
+}