summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-16 20:16:44 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-16 20:32:53 -0800
commit62cc80ec9e121ff1eefa0ee89f9741d7ff320289 (patch)
tree6b8b5a3b01fe6131d380bdbd1fd879fe931fbd82 /x11-libs/libdrm
parentapp-editors/hexedit: drop old (diff)
downloadgentoo-62cc80ec9e121ff1eefa0ee89f9741d7ff320289.tar.gz
gentoo-62cc80ec9e121ff1eefa0ee89f9741d7ff320289.tar.bz2
gentoo-62cc80ec9e121ff1eefa0ee89f9741d7ff320289.zip
x11-libs/libdrm: Version bump to 2.4.110
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.110.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index dac35302ce6c..75fca358f28f 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1 +1,2 @@
DIST libdrm-2.4.109.tar.xz 433708 BLAKE2B 99c612a4f9a8e9068debbecfc428f4af530705fca47df9c8e6f0fe6ed740610ded1db0d0e37a063ae893e1697c2f8c4dcc8e15b8909d8ba7c66cd941d7400d24 SHA512 45194bb28207421afcff3e247930d2eeab77a5fea58e6be22f67525f2e0aab2f410a9ae0ab315b55ef56b80c481bba40b1660468b7cda539758b2bbb8e814fd8
+DIST libdrm-2.4.110.tar.xz 436372 BLAKE2B 0d5f8bfe47bdcc96ef7dbe3ecf2da0b21262bae4396fa1e73c0f728d970d041a9925082c4526bc71e00f110c2eb0ba94313d9a7c27a2d4676073fdbc3708c628 SHA512 52f92ef1fe4c218a1d7dba53ef43334dbfca80e3209afe59f3a32c4bf67473126534e990df07a931a12d46a3b997c21ef17c1c4d8a0c88d44d5c6c040e3b6be3
diff --git a/x11-libs/libdrm/libdrm-2.4.110.ebuild b/x11-libs/libdrm/libdrm-2.4.110.ebuild
new file mode 100644
index 000000000000..15d2707a6f52
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.110.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/drm.git"
+PYTHON_COMPAT=( python3_{8..10} )
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} python-any-r1 meson-multilib
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')"
+
+python_check_deps() {
+ has_version -b "dev-python/docutils[${PYTHON_USEDEP}]"
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Udev is only used by tests now.
+ -Dudev=false
+ -Dcairo-tests=false
+ $(meson_use video_cards_amdgpu amdgpu)
+ $(meson_use video_cards_exynos exynos)
+ $(meson_use video_cards_freedreno freedreno)
+ $(meson_use video_cards_intel intel)
+ $(meson_use video_cards_nouveau nouveau)
+ $(meson_use video_cards_omap omap)
+ $(meson_use video_cards_radeon radeon)
+ $(meson_use video_cards_tegra tegra)
+ $(meson_use video_cards_vc4 vc4)
+ $(meson_use video_cards_vivante etnaviv)
+ $(meson_use video_cards_vmware vmwgfx)
+ $(meson_use libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ -Dvalgrind=$(usex valgrind auto false)
+ )
+ meson_src_configure
+}