summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-31 10:42:31 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-31 10:48:29 -0400
commitc87497c4f1b0a461426af9e5a6465c1493f39fb9 (patch)
tree22dde7628569c3d7b74ba0f29dfadcdc654a246e /x11-libs/libdrm
parentx11-libs/libdrm: Don't build tests (diff)
downloadgentoo-c87497c4f1b0a461426af9e5a6465c1493f39fb9.tar.gz
gentoo-c87497c4f1b0a461426af9e5a6465c1493f39fb9.tar.bz2
gentoo-c87497c4f1b0a461426af9e5a6465c1493f39fb9.zip
x11-libs/libdrm: Version bump to 2.4.113
Closes: https://bugs.gentoo.org/864529 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.113.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 41ba4ec1362d..2eded30e2663 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1 +1,2 @@
DIST libdrm-2.4.112.tar.xz 451872 BLAKE2B a41cbd714e169edd8c6bc6bba5cec8a7a703f553665575c35f43909e2927ed3c1652ddba25b98e63974f0734ca26e818e6ee75613159eb68ea85ba45934df393 SHA512 df8a207d9cce220ee2cf67877eda65394733fbfd0ff85fdbadb2b20ba9bacc41421b32452506c8caecddaf8361564ca68cd6c74d4faf3b1569ab30a3243e4340
+DIST libdrm-2.4.113.tar.xz 457064 BLAKE2B 30dab032f047a4bd3646b53c64c118d02855ee003025bb97b904f95101d2e945b0ed3d9ae00eb733f9a273afca3c18d10fa215b67c9c364a9819140a99d40115 SHA512 fca9834ce090f63ce6dc6d04491a2c5e86162fdddfc8ea70d55a6cdeb401be656388aae1577e58f463a78d8dc502be0a641908784819874e20bbec9a39a057e0
diff --git a/x11-libs/libdrm/libdrm-2.4.113.ebuild b/x11-libs/libdrm/libdrm-2.4.113.ebuild
new file mode 100644
index 000000000000..efae644e1d3b
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.113.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/drm.git"
+PYTHON_COMPAT=( python3_{8..11} )
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} python-any-r1 meson-multilib
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} valgrind"
+RESTRICT="test" # see bug #236845
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')"
+
+python_check_deps() {
+ python_has_version "dev-python/docutils[${PYTHON_USEDEP}]"
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Udev is only used by tests now.
+ -Dudev=false
+ -Dcairo-tests=disabled
+ $(meson_feature video_cards_amdgpu amdgpu)
+ $(meson_feature video_cards_exynos exynos)
+ $(meson_feature video_cards_freedreno freedreno)
+ $(meson_feature video_cards_intel intel)
+ $(meson_feature video_cards_nouveau nouveau)
+ $(meson_feature video_cards_omap omap)
+ $(meson_feature video_cards_radeon radeon)
+ $(meson_feature video_cards_tegra tegra)
+ $(meson_feature video_cards_vc4 vc4)
+ $(meson_feature video_cards_vivante etnaviv)
+ $(meson_feature video_cards_vmware vmwgfx)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ -Dvalgrind=$(usex valgrind auto disabled)
+ -Dtests=false # Tests are restricted
+ )
+ meson_src_configure
+}