summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-30 00:05:46 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-30 00:22:12 +0200
commit79f89dbd01e97c279c4ccf0d2453b1834d97934c (patch)
tree91f1223d4a51bb97c878a7ba95951e43cff23d4e /x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild
parentx11-libs/libtinynotify-cli: Moved back to GitHub (diff)
downloadgentoo-79f89dbd01e97c279c4ccf0d2453b1834d97934c.tar.gz
gentoo-79f89dbd01e97c279c4ccf0d2453b1834d97934c.tar.bz2
gentoo-79f89dbd01e97c279c4ccf0d2453b1834d97934c.zip
x11-libs/libtinynotify-cli: Modernize to EAPI=6
Diffstat (limited to 'x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild')
-rw-r--r--x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild b/x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild
index 589149d0761e..d71dbc25ec9e 100644
--- a/x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild
+++ b/x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=6
MY_P=tinynotify-send-${PV}
DESCRIPTION="Common CLI routines for tinynotify-send & sw-notify-send"
@@ -15,20 +13,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs"
-RDEPEND="x11-libs/libtinynotify"
+RDEPEND="x11-libs/libtinynotify:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( dev-util/gtk-doc )"
-DOCS=( README )
S=${WORKDIR}/${MY_P}
src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
--disable-regular
--disable-system-wide
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}