summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-29 23:49:17 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-30 00:22:05 +0200
commit5ef6b494299cb8305db058a9e029f909a34fabe2 (patch)
tree84e9dd740b237e56c8c86170411a2f8dc8d0a12e /x11-libs/libtinynotify
parentx11-libs/libtinynotify: Moved back to GitHub (diff)
downloadgentoo-5ef6b494299cb8305db058a9e029f909a34fabe2.tar.gz
gentoo-5ef6b494299cb8305db058a9e029f909a34fabe2.tar.bz2
gentoo-5ef6b494299cb8305db058a9e029f909a34fabe2.zip
x11-libs/libtinynotify: Modernize to EAPI=6
Diffstat (limited to 'x11-libs/libtinynotify')
-rw-r--r--x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild16
-rw-r--r--x11-libs/libtinynotify/libtinynotify-9999.ebuild35
2 files changed, 27 insertions, 24 deletions
diff --git a/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
index e6530951b7dd..b87cfbb96ab0 100644
--- a/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
+++ b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=6
DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
HOMEPAGE="https://github.com/mgorny/libtinynotify/"
@@ -14,7 +12,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc static-libs"
-RDEPEND="sys-apps/dbus"
+RDEPEND="sys-apps/dbus:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( >=dev-util/gtk-doc-1.18 )"
@@ -22,10 +20,16 @@ DEPEND="${RDEPEND}
DOCS=( README )
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_enable debug)
$(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
}
diff --git a/x11-libs/libtinynotify/libtinynotify-9999.ebuild b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
index 6d11440f4c25..c2e029412ac2 100644
--- a/x11-libs/libtinynotify/libtinynotify-9999.ebuild
+++ b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
@@ -1,43 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
-
-inherit git-r3
-#endif
-
-inherit autotools-utils
+inherit autotools git-r3
DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
HOMEPAGE="https://github.com/mgorny/libtinynotify/"
-SRC_URI="https://github.com/mgorny/libtinynotify/releases/download/${P}/${P}.tar.bz2"
+SRC_URI=""
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE="debug doc static-libs"
RDEPEND="sys-apps/dbus:0="
DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-1.18
virtual/pkgconfig
doc? ( >=dev-util/gtk-doc-1.18 )"
-#if LIVE
-KEYWORDS=
-SRC_URI=
-DEPEND="${DEPEND}
- >=dev-util/gtk-doc-1.18"
-#endif
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_enable debug)
$(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
}