summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-17 09:15:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-17 09:20:29 +0200
commitfc12b377b092fd914cd742ab90e8f0a9f7590b96 (patch)
tree2e3b33d213652046be47bb516f9d68e7474e33b1 /x11-libs/libva-intel-driver
parentx11-libs/libva-intel-driver: Remove old (diff)
downloadgentoo-fc12b377b092fd914cd742ab90e8f0a9f7590b96.tar.gz
gentoo-fc12b377b092fd914cd742ab90e8f0a9f7590b96.tar.bz2
gentoo-fc12b377b092fd914cd742ab90e8f0a9f7590b96.zip
x11-libs/libva-intel-driver: bump to 2.2.0
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'x11-libs/libva-intel-driver')
-rw-r--r--x11-libs/libva-intel-driver/Manifest1
-rw-r--r--x11-libs/libva-intel-driver/libva-intel-driver-2.2.0.ebuild55
-rw-r--r--x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild5
3 files changed, 58 insertions, 3 deletions
diff --git a/x11-libs/libva-intel-driver/Manifest b/x11-libs/libva-intel-driver/Manifest
index aa35f0fa3c62..bc92f2ccae45 100644
--- a/x11-libs/libva-intel-driver/Manifest
+++ b/x11-libs/libva-intel-driver/Manifest
@@ -1,3 +1,4 @@
DIST libva-intel-driver-1.7.3.tar.gz 1648659 BLAKE2B 5d5bf82d02c6e887f4afd332fa395e3044ac9b9bbf8e1682aeaf80d6c61c1db537b27ed22b25e932ec71d9011af07d9008f64df2e7c77a2c6f9dd0e10860d41f SHA512 57ae4fbf1bd5799e8a311fcd67eda1a8a6d5b5267df502b83f63f8bd0cdd510a4f78b4d09088833bfa2e98447d841c3d4e7229f4e75a9d9f4b8096fb14027878
DIST libva-intel-driver-1.8.3.tar.gz 2591242 BLAKE2B 954ad024ea93073f23045530506c6988cd55bc4bce565856071b30cfc0c10b673a225d4cfdd50cd360a3f828bf236386ba2937e59c260f72717dbdf72a29152c SHA512 0457147aa998014df82ef6180c873fd087b03573adac7ba84c79516a16bd73eb43ff5f07cf3f40c7f590f4e04981ae3010877a468fb20fe4606843932aaa0990
DIST libva-intel-driver-2.1.0.tar.gz 3954965 BLAKE2B 6ff759860477896df6ee433d7b1ff8f3fda498e98210bfcbec33dc663a65bc07b8304ae219885225985fc65a785d7510aacb785a17d9fd66fb1c16a0ca7ffd57 SHA512 2df0d617a4a64ee37641fd9134f8455f59160d003c252b0e82f7be47adaad7d531f9f2f3ab16d75457b2852e8893887d5be6da5f8128e64ffe8311853baf6453
+DIST libva-intel-driver-2.2.0.tar.gz 3966600 BLAKE2B 859bf9a51cabf4736b897bc3189ad20f1d36f9f7ee0acdf828a358e9aaed2d20f4908ad214befbd729f1dbce94d7328018376bc6a2a72e625687e8f8a7131364 SHA512 8843e184c0d4d98a694f4fb1ba692a63795968879257b5f791f9bdf2a32e3d0fe3f9cac46533d78721d91c949063778e97b58bbbc1ba4da95b53b306c04e8e90
diff --git a/x11-libs/libva-intel-driver/libva-intel-driver-2.2.0.ebuild b/x11-libs/libva-intel-driver/libva-intel-driver-2.2.0.ebuild
new file mode 100644
index 000000000000..92d13cf8a5b3
--- /dev/null
+++ b/x11-libs/libva-intel-driver/libva-intel-driver-2.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/intel-vaapi-driver"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="HW video decode support for Intel integrated graphics"
+HOMEPAGE="https://github.com/intel/intel-vaapi-driver"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/intel/intel-vaapi-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/intel-vaapi-driver-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="wayland X"
+
+RDEPEND=">=x11-libs/libva-2.0.0:=[X?,wayland?,drm,${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.52[video_cards_intel,${MULTILIB_USEDEP}]
+ wayland? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
+
+src_prepare() {
+ sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild b/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
index a440f5228714..92d13cf8a5b3 100644
--- a/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
+++ b/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
@@ -29,9 +29,9 @@ if [ "${PV%9999}" = "${PV}" ] ; then
else
KEYWORDS=""
fi
-IUSE="+drm wayland X"
+IUSE="wayland X"
-RDEPEND=">=x11-libs/libva-2.0.0:=[X?,wayland?,drm?,${MULTILIB_USEDEP}]
+RDEPEND=">=x11-libs/libva-2.0.0:=[X?,wayland?,drm,${MULTILIB_USEDEP}]
>=x11-libs/libdrm-2.4.52[video_cards_intel,${MULTILIB_USEDEP}]
wayland? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}] )"
@@ -48,7 +48,6 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
- $(use_enable drm)
$(use_enable wayland)
$(use_enable X x11)
)