summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libwnck/libwnck-2.31.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libwnck/libwnck-2.31.0.ebuild')
-rw-r--r--x11-libs/libwnck/libwnck-2.31.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/libwnck/libwnck-2.31.0.ebuild b/x11-libs/libwnck/libwnck-2.31.0.ebuild
new file mode 100644
index 000000000000..d917a6f54cb7
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-2.31.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2+"
+SLOT="1"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE="+introspection startup-notification"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.19.7:2[introspection?]
+ >=dev-libs/glib-2.16:2
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ x86-interix? ( sys-libs/itx-bind )
+"
+# eautoreconf needs
+# gnome-base/gnome-common
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ # Regenerate pregenerated marshalers for <glib-2.31 compatibility
+ rm -v libwnck/wnck-marshal.{c,h} || die "rm failed"
+
+ gnome2_src_prepare
+
+ if use x86-interix; then
+ # activate the itx-bind package...
+ append-flags "-I${EPREFIX}/usr/include/bind"
+ append-ldflags "-L${EPREFIX}/usr/lib/bind"
+ fi
+}
+
+src_configure () {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}