summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-03-05 11:39:27 -0800
committerMatt Turner <mattst88@gentoo.org>2018-03-05 11:46:19 -0800
commit0e63133704436a0197b34e1eaa2efc8027477440 (patch)
tree9436da2e7481210c087d473f7ef34803115184eb /x11-libs/libxcb/libxcb-1.13.ebuild
parentx11-proto/xcb-proto: Version bump to 1.13 (diff)
downloadgentoo-0e63133704436a0197b34e1eaa2efc8027477440.tar.gz
gentoo-0e63133704436a0197b34e1eaa2efc8027477440.tar.bz2
gentoo-0e63133704436a0197b34e1eaa2efc8027477440.zip
x11-libs/libxcb: Version bump to 1.13
Diffstat (limited to 'x11-libs/libxcb/libxcb-1.13.ebuild')
-rw-r--r--x11-libs/libxcb/libxcb-1.13.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/libxcb/libxcb-1.13.ebuild b/x11-libs/libxcb/libxcb-1.13.ebuild
new file mode 100644
index 000000000000..a8f6ab111833
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE=xml
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit python-any-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="https://xcb.freedesktop.org/"
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/xcb/libxcb.git"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc selinux test xkb"
+SLOT="0/1.12"
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+ doc? ( app-doc/doxygen[dot] )
+ dev-libs/libxslt
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep \
+ ">=x11-proto/xcb-proto-1.13[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
+
+python_check_deps() {
+ has_version --host-root ">=x11-proto/xcb-proto-1.13[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc devel-docs)
+ $(use_enable selinux)
+ $(use_enable xkb)
+ --enable-xinput
+ )
+ xorg-2_src_configure
+}