summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-26 13:41:32 -0700
committerMatt Turner <mattst88@gentoo.org>2021-07-07 18:25:57 -0700
commit2ce34ec9778387d335c1537bb2325ecc359fb452 (patch)
tree73fe5d8480e461d8b076fe29ce16eef1f49c49dc /x11-libs/libxcvt/libxcvt-0.1.0.ebuild
parentkernel-install.eclass: print uname() info after test (diff)
downloadgentoo-2ce34ec9778387d335c1537bb2325ecc359fb452.tar.gz
gentoo-2ce34ec9778387d335c1537bb2325ecc359fb452.tar.bz2
gentoo-2ce34ec9778387d335c1537bb2325ecc359fb452.zip
x11-libs/libxcvt: Add new package
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxcvt/libxcvt-0.1.0.ebuild')
-rw-r--r--x11-libs/libxcvt/libxcvt-0.1.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11-libs/libxcvt/libxcvt-0.1.0.ebuild b/x11-libs/libxcvt/libxcvt-0.1.0.ebuild
new file mode 100644
index 000000000000..0ad3f5af940d
--- /dev/null
+++ b/x11-libs/libxcvt/libxcvt-0.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_TARBALL_SUFFIX="xz"
+
+inherit xorg-3 meson
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="X.Org xcvt library and cvt program"
+
+RDEPEND="!<x11-base/xorg-server-1.20.11-r3"
+
+# Override xorg-3's src_prepare
+src_prepare() {
+ default
+}