summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-24 14:31:24 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-24 14:32:40 -0400
commit836bf743ba70b30946b28680d8c6554e3eaf1cb7 (patch)
tree5a61bd42b71678bd228345160305eeb410da2c27 /x11-libs/libxkbcommon
parentdev-python/pysimdjson: enable py3.11 (diff)
downloadgentoo-836bf743ba70b30946b28680d8c6554e3eaf1cb7.tar.gz
gentoo-836bf743ba70b30946b28680d8c6554e3eaf1cb7.tar.bz2
gentoo-836bf743ba70b30946b28680d8c6554e3eaf1cb7.zip
x11-libs/libxkbcommon: Version bump to 1.4.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.4.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 52bc9955af84..f5eeaebb45e9 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,2 +1,3 @@
DIST libxkbcommon-1.3.1.tar.xz 471036 BLAKE2B c46d39876bd4477fe838e17e744ed04388417cfae8bb77c7de48237d31f51fe230d2705733dc0873253b48c61530fbe932e4da7317217c31a7897702fa1d03b4 SHA512 3b2cf6ae9ba4dc8b6fe702ac1fa700034fbc9bd147c73bd2cd93546bcfb71865734b3e46bad35a8fd618ed97266a02dad1dc966c63e6b10404a64919459d933e
DIST libxkbcommon-1.4.0.tar.xz 471948 BLAKE2B 5b0a155a3a47adb7302db01f3daa0ef81993a9754b032b01f1cdbd53af74d15df95dc6c9334860211a28272b246f66978ad6e409db74a242afb13c17dc25b76e SHA512 7dd86952c036a6a78455b1ba05b53fcff9d6f133bb01c83fa860b4eaec3fc26bb0b5535948bcc2dafbd27204c3c91d01404ca9fc52896cc36af509384797d4f1
+DIST libxkbcommon-1.4.1.tar.xz 471824 BLAKE2B a784f3612bb52abb79bf1a2ddd3e7709fa52eddce5cabcf8520ed7df8ec8ea557e51205e1e9d116a0b31eb27b1f3bca33144318c5f01be7312cbb3e48f687fbe SHA512 757b340aeab6d187917807a88015b5113475ab2172aaaa8e530b40ea60619b3fbdfa668fd62707d66ed8fb763e68fee19394fcbd519af7c01d8975c59fdf0d89
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.4.1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.4.1.ebuild
new file mode 100644
index 000000000000..23a22a86c0b6
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ wayland? ( dev-util/wayland-scanner )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ wayland? ( >=dev-libs/wayland-1.2.0 )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}