summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libyui-gtk/libyui-gtk-2.44.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libyui-gtk/libyui-gtk-2.44.5.ebuild')
-rw-r--r--x11-libs/libyui-gtk/libyui-gtk-2.44.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-libs/libyui-gtk/libyui-gtk-2.44.5.ebuild b/x11-libs/libyui-gtk/libyui-gtk-2.44.5.ebuild
new file mode 100644
index 000000000000..0b3e410e0314
--- /dev/null
+++ b/x11-libs/libyui-gtk/libyui-gtk-2.44.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="UI abstraction library - GTK plugin"
+HOMEPAGE="https://github.com/libyui/libyui-gtk"
+SRC_URI="https://github.com/libyui/${PN}/archive/${PN}/master/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ x11-libs/libyui:${SLOT}
+"
+# Only Boost headers are needed
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+S="${WORKDIR}/${PN}-${PN}-master-${PV}"
+
+src_prepare() {
+ cp "${EPREFIX}/usr/share/libyui/buildtools/CMakeLists.common" CMakeLists.txt || die
+
+ # TODO: set proper docs deps and USE flag for building them
+ sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+ sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_WERROR=OFF
+ -DDOC_DIR="${EPREFIX}/usr/share/doc/${P}"
+ -DRESPECT_FLAGS=ON
+ $(cmake-utils_use_enable static-libs STATIC)
+ )
+ cmake-utils_src_configure
+}