summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-11-23 10:23:02 +0100
committerUlrich Müller <ulm@gentoo.org>2022-11-23 10:24:12 +0100
commitaf0fe7b8933f09dbb41227b43c7d4d831b3c162d (patch)
tree178e5570f7c7a24491e149da3a24f529aded369d /x11-libs/motif
parentmedia-sound/snd: dropped obsolete 17.4 & 22.8 (diff)
downloadgentoo-af0fe7b8933f09dbb41227b43c7d4d831b3c162d.tar.gz
gentoo-af0fe7b8933f09dbb41227b43c7d4d831b3c162d.tar.bz2
gentoo-af0fe7b8933f09dbb41227b43c7d4d831b3c162d.zip
x11-libs/motif: Fix some function declarations
Closes: https://bugs.gentoo.org/864533 Closes: https://bugs.gentoo.org/870799 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'x11-libs/motif')
-rw-r--r--x11-libs/motif/Manifest1
-rw-r--r--x11-libs/motif/motif-2.3.8-r4.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/x11-libs/motif/Manifest b/x11-libs/motif/Manifest
index 72c74a1b5d51..6610f8cf27ff 100644
--- a/x11-libs/motif/Manifest
+++ b/x11-libs/motif/Manifest
@@ -1,2 +1,3 @@
DIST motif-2.3.8-patches-2.tar.xz 4068 BLAKE2B 5466f824d71edd1d787eebe5b1fa09de5b52ffa20cdf733301722c4f1d7509af8084f226d68dcba14c2e8d15d5b1ea7d49e408eea8f710af3c0b27c86aba444c SHA512 27e10c2a5b3dec8597acb04940bb8e000fc43c325e5b6f578246ab4187ef34264940369bff1e9c999ba967e85e093434e16a447f1d4da805d0a5ab1576e5ef80
+DIST motif-2.3.8-patches-3.tar.xz 4520 BLAKE2B 23c9814422ef66dd21d0175aa0d180bf0563ad3e67ef9a18121658231392902005afa94e990853b570fb80ef62cf09f1b5dfc62594db4beea1808933d1e9edbe SHA512 46c3177f0d9d12701a4ca7a33b6792c545d61f41421abc911c21e17842e88576d37bfa86dc882e55b50e7c73122c49f5d6bc32f42dc72b3f5f4feacd37857de8
DIST motif-2.3.8.tar.gz 5704328 BLAKE2B 3755b7f46e50240e1e9e7046aa439fa89872e54ae5d03860383f509b6d0f09edf85bd7d92ea4d37925efd2e44401028aa2752d940c42d9cccb652b2bd1d85459 SHA512 1ab8e8eece25ef97e948592b5fa3e19d98e932695290a18b7a8e90f1aa2766bc4f082bdbc3999dff5660e684821178a149040f76bb477163e53ca06474d02b55
diff --git a/x11-libs/motif/motif-2.3.8-r4.ebuild b/x11-libs/motif/motif-2.3.8-r4.ebuild
new file mode 100644
index 000000000000..36c24b444eab
--- /dev/null
+++ b/x11-libs/motif/motif-2.3.8-r4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="The Motif user interface component toolkit"
+HOMEPAGE="https://sourceforge.net/projects/motif/
+ https://motif.ics.com/"
+SRC_URI="mirror://sourceforge/project/motif/Motif%20${PV}%20Source%20Code/${P}.tar.gz
+ https://dev.gentoo.org/~ulm/distfiles/${P}-patches-3.tar.xz"
+
+LICENSE="LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples jpeg +motif22-compatibility png static-libs unicode xft"
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ jpeg? ( >=media-libs/libjpeg-turbo-1.5.3-r2:0=[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
+ unicode? ( >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}] )
+ xft? (
+ >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ )"
+
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-misc/xbitmaps"
+
+BDEPEND="sys-devel/flex
+ dev-util/byacc"
+
+src_prepare() {
+ eapply ../patch
+ eapply_user
+
+ # remove files generated by flex #864533
+ rm tools/wml/{wmllex,wmluiltok}.c || die
+
+ AT_M4DIR=. eautoreconf
+
+ # get around some LANG problems in make (#15119)
+ LANG=C
+
+ # bug #80421
+ filter-flags -ftracer
+
+ # feel free to fix properly if you care
+ append-flags -fno-strict-aliasing
+
+ # for Solaris Xos_r.h :(
+ [[ ${CHOST} == *-solaris2.11 ]] \
+ && append-cppflags -DNEED_XOS_R_H -DHAVE_READDIR_R_3
+
+ if use !elibc_glibc && use !elibc_musl && use unicode; then
+ # libiconv detection in configure script doesn't always work
+ # http://bugs.motifzone.net/show_bug.cgi?id=1423
+ export LIBS="${LIBS} -liconv"
+ fi
+
+ # "bison -y" causes runtime crashes #355795
+ export YACC=byacc
+
+ # remember the name of the C compiler for the native ABI
+ MY_NATIVE_CC=$(tc-getCC)
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-x \
+ --disable-printing \
+ $(use_enable static-libs static) \
+ $(use_enable motif22-compatibility) \
+ $(use_enable unicode utf8) \
+ $(use_enable xft) \
+ $(use_enable jpeg) \
+ $(use_enable png)
+}
+
+multilib_src_compile() {
+ # The wmluiltok build tool is linked with libfl.a, so always
+ # compile it for the native ABI
+ emake -C tools/wml CC="${MY_NATIVE_CC}" LIBS="-lfl" wmluiltok
+ emake
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use examples; then
+ emake -C demos DESTDIR="${D}" install-data
+ dodir /usr/share/doc/${PF}/demos
+ mv "${ED}"/usr/share/Xm/* "${ED}"/usr/share/doc/${PF}/demos || die
+ fi
+}
+
+multilib_src_install_all() {
+ # mwm default configs
+ insinto /usr/share/X11/app-defaults
+ newins "${FILESDIR}"/Mwm.defaults Mwm
+
+ # cleanup
+ rm -rf "${ED}"/usr/share/Xm || die
+ find "${D}" -type f -name "*.la" -delete || die
+
+ dodoc BUGREPORT ChangeLog README RELEASE RELNOTES TODO
+}