summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-17 18:45:53 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-17 22:47:09 -0500
commit8a31c6f3dc0c8aaffd89ba47ddad8fc5cf7e3f15 (patch)
treefff51315bf679d44a3ba2f3c388df422048d7dd4 /x11-libs/pango
parentapp-shells/ksh: keyword 1.0.0_beta2 for ~sparc (diff)
downloadgentoo-8a31c6f3dc0c8aaffd89ba47ddad8fc5cf7e3f15.tar.gz
gentoo-8a31c6f3dc0c8aaffd89ba47ddad8fc5cf7e3f15.tar.bz2
gentoo-8a31c6f3dc0c8aaffd89ba47ddad8fc5cf7e3f15.zip
x11-libs/pango: Version bump to 1.50.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.50.2.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index 9e8a7cd33f8c..4fd2bfbddf5f 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -4,3 +4,4 @@ DIST pango-1.48.10.tar.xz 2071736 BLAKE2B 68bca7e8307fc7ddb49830c84b17e95fbb1f2e
DIST pango-1.48.5.tar.xz 1819476 BLAKE2B 8529e8cbcf0f33be56cf09229abe45fb3525e12a9c2a6ad7cca416ff67a92eb010abc2ce814fa4d19a924186369eede4a576efdd2f4c64b39e31c9821c5e414a SHA512 2c758e649af5b9f9fa960c26a6f4dcf5abd8035101fdfe4a02fe02cb892250b615584b02d63aaa06f3da5cbe7bb848459ac969f43437c34cec084b51bcf48cab
DIST pango-1.48.7.tar.xz 2050880 BLAKE2B 2ee048d9713aed0972ffdf3feb96c7c0683ffa1494ac2b798a4f6b1f5797d689b0e0c06bcc3f4a10130d23279ed295a3a59141c75bd3a0f2da7facf62d6c3baa SHA512 e5680d628f531bea7633945bd74dc51a93c4c881dec58fcf9f6271043e77b82a4805e311355cb4d9f8cdfcdf52785a5a6391517a264b62416c26e82dff4aca39
DIST pango-1.48.9.tar.xz 2063756 BLAKE2B d1610aaac783b95a35ad3e083b4bab33f3d4beff533386817addcb5eb9022de242087ffe4e62c043870b4aac1fbc0fe3e1c5d18744909a5a05015a702dfea2e3 SHA512 e3bba743bb596b0a34cedc893f9af0216bcc9fec521c2da09cfdeec9ad80a05b5c53c3fce1a225ab27536e9335725cffb87c66867d0522fd4632df00b1d4c056
+DIST pango-1.50.2.tar.xz 4089160 BLAKE2B 3b752d72ab3c656c23efa591a8508ed52475e73ea329984c11aacaca4a1f4ebee68bdc4000104d2150b01a452215d6b3fc9ac5c50a71b4b2ddca78d1aed231e9 SHA512 e85898370c68ee91391f926aaab046763b6b6086fd892e1a7d98bf83787bcca9c463f3ccb4a2fc4b8f248722a8a229bb52363f799c8bc4040eeb94028c6361b6
diff --git a/x11-libs/pango/pango-1.50.2.ebuild b/x11-libs/pango/pango-1.50.2.ebuild
new file mode 100644
index 000000000000..b756a9e7e501
--- /dev/null
+++ b/x11-libs/pango/pango-1.50.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/ https://gitlab.gnome.org/GNOME/pango"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug +introspection sysprof X"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.6.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.13.0:1.0=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ if use debug; then
+ append-cflags -DPANGO_ENABLE_DEBUG
+ else
+ append-cflags -DG_DISABLE_CAST_CHECKS
+ fi
+
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_native_use_feature introspection)
+ -Dinstall-tests=false
+ -Dfontconfig=enabled
+ $(meson_feature sysprof)
+ -Dlibthai=disabled
+ -Dcairo=enabled
+ $(meson_feature X xft)
+ -Dfreetype=enabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ insinto /usr/share/gtk-doc/html
+ # This will install PangoXft API docs regardless of USE=-X, but this is intentional
+ doins -r "${S}"/docs/Pango*
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}