summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-02 23:10:03 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-02 23:10:03 +0100
commit81e66f7cf5a690b0a56f796f7dba8e04e9d4be0f (patch)
treeb953a28bf2e3c0afa405b7fabcf2c63198af2592 /x11-libs/pixman/pixman-0.34.0.ebuild
parentapp-crypt/easy-rsa: Add myself as maintainer (diff)
downloadgentoo-81e66f7cf5a690b0a56f796f7dba8e04e9d4be0f.tar.gz
gentoo-81e66f7cf5a690b0a56f796f7dba8e04e9d4be0f.tar.bz2
gentoo-81e66f7cf5a690b0a56f796f7dba8e04e9d4be0f.zip
x11-libs/pixman: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-libs/pixman/pixman-0.34.0.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.34.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/pixman/pixman-0.34.0.ebuild b/x11-libs/pixman/pixman-0.34.0.ebuild
new file mode 100644
index 000000000000..8448e32219bd
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.34.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+if [[ $PV = 9999* ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+IUSE="altivec iwmmxt loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable cpu_flags_x86_mmxext mmx)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable cpu_flags_x86_ssse3 ssse3)
+ $(use_enable altivec vmx)
+ $(use_enable neon arm-neon)
+ $(use_enable iwmmxt arm-iwmmxt)
+ $(use_enable loongson2f loongson-mmi)
+ --disable-gtk
+ --disable-libpng
+ )
+ xorg-2_src_configure
+}