summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-06-17 11:40:52 -0400
committerMatt Turner <mattst88@gentoo.org>2019-06-17 11:42:04 -0400
commit43dafe5bc3206ad6336d7d68c18eb79ecf5a0710 (patch)
tree01156803b711bbdfd266ec09d3361aff839e021a /x11-libs/pixman/pixman-0.38.4.ebuild
parentx11-libs/libX11: Version bump to 1.6.8 (diff)
downloadgentoo-43dafe5bc3206ad6336d7d68c18eb79ecf5a0710.tar.gz
gentoo-43dafe5bc3206ad6336d7d68c18eb79ecf5a0710.tar.bz2
gentoo-43dafe5bc3206ad6336d7d68c18eb79ecf5a0710.zip
x11-libs/pixman: Use tc-has-openmp
Closes: https://bugs.gentoo.org/684656 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pixman/pixman-0.38.4.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.38.4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/x11-libs/pixman/pixman-0.38.4.ebuild b/x11-libs/pixman/pixman-0.38.4.ebuild
index 3fbd5e9c8325..b5fcceac9572 100644
--- a/x11-libs/pixman/pixman-0.38.4.ebuild
+++ b/x11-libs/pixman/pixman-0.38.4.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson multilib-minimal
+inherit ${GIT_ECLASS} meson multilib-minimal toolchain-funcs
DESCRIPTION="Low-level pixel manipulation routines"
HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -30,6 +30,9 @@ src_unpack() {
}
multilib_src_configure() {
+ local openmp=disabled
+ tc-has-openmp && openmp=enabled
+
local emesonargs=(
$(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
$(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
@@ -41,7 +44,7 @@ multilib_src_configure() {
$(meson_feature loongson2f loongson-mmi)
-Dgtk=disabled
-Dlibpng=disabled
- -Dopenmp=auto # only used in unit tests
+ -Dopenmp=$openmp # only used in unit tests
)
meson_src_configure
}