summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-04-10 10:26:29 -0700
committerMatt Turner <mattst88@gentoo.org>2019-04-10 10:28:36 -0700
commitdfc4f932e39bd052cab7b40d523acedbc1f0a448 (patch)
treed84051ac32d0d565461e48987f141fc19b06de62 /x11-libs/pixman/pixman-0.38.4.ebuild
parentdev-ruby/psych: cleanup (diff)
downloadgentoo-dfc4f932e39bd052cab7b40d523acedbc1f0a448.tar.gz
gentoo-dfc4f932e39bd052cab7b40d523acedbc1f0a448.tar.bz2
gentoo-dfc4f932e39bd052cab7b40d523acedbc1f0a448.zip
x11-libs/pixman: Version bump to 0.38.4
Closes: https://bugs.gentoo.org/683042 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pixman/pixman-0.38.4.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.38.4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/pixman/pixman-0.38.4.ebuild b/x11-libs/pixman/pixman-0.38.4.ebuild
new file mode 100644
index 000000000000..58862e4166be
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.38.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
+ $(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature altivec vmx)
+ $(meson_feature neon neon)
+ $(meson_feature loongson2f loongson-mmi)
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ -Dopenmp=auto # only used in unit tests
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson test -v -C "${BUILD_DIR}" -t 100
+}
+
+multilib_src_install() {
+ meson_src_install
+}