summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:51:48 +0200
committerSam James <sam@gentoo.org>2022-05-15 01:18:12 +0000
commit0ba7cfeffd00d23f6dbb19913f680959809cf222 (patch)
tree6c1a18a11ca4da5736d6d2498defeec220dd9762 /x11-libs/pixman
parentsys-apps/etckeeper: add 1.18.17 (diff)
downloadgentoo-0ba7cfeffd00d23f6dbb19913f680959809cf222.tar.gz
gentoo-0ba7cfeffd00d23f6dbb19913f680959809cf222.tar.bz2
gentoo-0ba7cfeffd00d23f6dbb19913f680959809cf222.zip
x11-libs/pixman: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/pixman-0.40.0.ebuild16
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild16
2 files changed, 22 insertions, 10 deletions
diff --git a/x11-libs/pixman/pixman-0.40.0.ebuild b/x11-libs/pixman/pixman-0.40.0.ebuild
index d74622ede459..795b17992f52 100644
--- a/x11-libs/pixman/pixman-0.40.0.ebuild
+++ b/x11-libs/pixman/pixman-0.40.0.ebuild
@@ -22,12 +22,18 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs test"
+RESTRICT="!test? ( test )"
-multilib_src_configure() {
- local openmp=disabled
- tc-has-openmp && openmp=enabled
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+multilib_src_configure() {
if use arm && tc-is-clang ; then
# See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
append-cflags $(test-flags-CC -fno-integrated-as)
@@ -42,10 +48,10 @@ multilib_src_configure() {
$(meson_feature cpu_flags_ppc_altivec vmx)
$(meson_feature cpu_flags_arm_neon neon)
$(meson_feature loongson2f loongson-mmi)
+ $(meson_feature test openmp) # only used in unit tests
-Ddefault_library=$(usex static-libs both shared)
-Dgtk=disabled
-Dlibpng=disabled
- -Dopenmp=$openmp # only used in unit tests
)
meson_src_configure
}
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index b1bf1b2339dd..ee72ddca48c6 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -22,12 +22,18 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs test"
+RESTRICT="!test? ( test )"
-multilib_src_configure() {
- local openmp=disabled
- tc-has-openmp && openmp=enabled
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+multilib_src_configure() {
if use arm && tc-is-clang ; then
# See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
append-cflags $(test-flags-CC -fno-integrated-as)
@@ -42,10 +48,10 @@ multilib_src_configure() {
$(meson_feature cpu_flags_ppc_altivec vmx)
$(meson_feature cpu_flags_arm_neon neon)
$(meson_feature loongson2f loongson-mmi)
+ $(meson_feature test openmp) # only used in unit tests
-Ddefault_library=$(usex static-libs both shared)
-Dgtk=disabled
-Dlibpng=disabled
- -Dopenmp=$openmp # only used in unit tests
)
meson_src_configure
}