summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-29 11:44:20 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-29 11:52:36 -0500
commitd4cf1f51a0421a5e56c0d010bb86a5b057d67c11 (patch)
tree9501c6318d6db29aef82f9ca58bba4dfa292dddd /x11-libs/pixman
parentsys-kernel/gentoo-sources: drop 6.0.7 (diff)
downloadgentoo-d4cf1f51a0421a5e56c0d010bb86a5b057d67c11.tar.gz
gentoo-d4cf1f51a0421a5e56c0d010bb86a5b057d67c11.tar.bz2
gentoo-d4cf1f51a0421a5e56c0d010bb86a5b057d67c11.zip
x11-libs/pixman: Fix enabling neon on arm/arm64
Closes: https://bugs.gentoo.org/881169 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/pixman-0.42.2.ebuild9
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/x11-libs/pixman/pixman-0.42.2.ebuild b/x11-libs/pixman/pixman-0.42.2.ebuild
index 802e65eac019..4c274d484e3b 100644
--- a/x11-libs/pixman/pixman-0.42.2.ebuild
+++ b/x11-libs/pixman/pixman-0.42.2.ebuild
@@ -46,8 +46,6 @@ multilib_src_configure() {
$(meson_feature cpu_flags_x86_sse2 sse2)
$(meson_feature cpu_flags_x86_ssse3 ssse3)
$(meson_feature cpu_flags_ppc_altivec vmx)
- $(meson_feature cpu_flags_arm_neon neon)
- $(meson_feature cpu_flags_arm_neon a64-neon)
$(meson_feature loongson2f loongson-mmi)
$(meson_feature test openmp) # only used in unit tests
$(meson_feature test tests)
@@ -55,6 +53,13 @@ multilib_src_configure() {
-Dgtk=disabled
-Dlibpng=disabled
)
+
+ if [[ ${ABI} == arm64 ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon a64-neon))
+ elif [[ ${ABI} == arm ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon neon))
+ fi
+
meson_src_configure
}
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index 0fbef29030a3..1cd3dd3a43a8 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -46,8 +46,6 @@ multilib_src_configure() {
$(meson_feature cpu_flags_x86_sse2 sse2)
$(meson_feature cpu_flags_x86_ssse3 ssse3)
$(meson_feature cpu_flags_ppc_altivec vmx)
- $(meson_feature cpu_flags_arm_neon neon)
- $(meson_feature cpu_flags_arm_neon a64-neon)
$(meson_feature loongson2f loongson-mmi)
$(meson_feature test openmp) # only used in unit tests
$(meson_feature test tests)
@@ -55,6 +53,13 @@ multilib_src_configure() {
-Dgtk=disabled
-Dlibpng=disabled
)
+
+ if [[ ${ABI} == arm64 ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon a64-neon))
+ elif [[ ${ABI} == arm ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon neon))
+ fi
+
meson_src_configure
}