summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-07 22:51:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:48 +0100
commit275570b85ef152544baf54440e95d3183a8f4149 (patch)
treeb2d79b8daf3a33aaea81ed0dc4e15361ab9542cf /x11-libs/qtermwidget/qtermwidget-9999.ebuild
parentlxqt-base/lxqt-meta: version bump to 0.14.1 (diff)
downloadgentoo-275570b85ef152544baf54440e95d3183a8f4149.tar.gz
gentoo-275570b85ef152544baf54440e95d3183a8f4149.tar.bz2
gentoo-275570b85ef152544baf54440e95d3183a8f4149.zip
x11-libs/qtermwidget: bump to EAPI="7" and apply general updates
- Remove 'nofetch' patch, which does not apply any longer as it is, and upstream has changed their translation set-up away from 'lxqt-base/lxqt-l10n', so disabling them may need a different approach. - Bump the required 'lxqt-build-tools' version. - Use the same formatting for SRC_URI and friends, as is used in other related packages. - Update SRC_URI, HOMEPAGE, LICENSE, and SLOT. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs/qtermwidget/qtermwidget-9999.ebuild')
-rw-r--r--x11-libs/qtermwidget/qtermwidget-9999.ebuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/x11-libs/qtermwidget/qtermwidget-9999.ebuild b/x11-libs/qtermwidget/qtermwidget-9999.ebuild
index cda15baf682a..9c367cc15cbc 100644
--- a/x11-libs/qtermwidget/qtermwidget-9999.ebuild
+++ b/x11-libs/qtermwidget/qtermwidget-9999.ebuild
@@ -1,26 +1,31 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils git-r3
+EAPI=7
+
+inherit cmake-utils
DESCRIPTION="Qt terminal emulator widget"
-HOMEPAGE="https://github.com/lxde/qtermwidget"
-EGIT_REPO_URI="https://github.com/lxde/qtermwidget.git"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
+LICENSE="BSD GPL-2 LGPL-2+"
+SLOT="0/${PV}"
-RDEPEND="
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
"
-DEPEND="${DEPEND}
- dev-util/lxqt-build-tools
- dev-qt/linguist-tools:5
-"
-
-PATCHES=( "${FILESDIR}/${P}-nofetch.patch" )
+RDEPEND="${DEPEND}"