summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-22 17:34:59 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-25 11:25:03 -0400
commit4ec07916ba1f014f254343f0ebbae84e6806837c (patch)
treef5afc2e549687f897c9f40f3469535e795fa0b39 /x11-libs/vte
parentgui-libs/vte: Version bump to 0.70.1 (diff)
downloadgentoo-4ec07916ba1f014f254343f0ebbae84e6806837c.tar.gz
gentoo-4ec07916ba1f014f254343f0ebbae84e6806837c.tar.bz2
gentoo-4ec07916ba1f014f254343f0ebbae84e6806837c.zip
x11-libs/vte: Version bump to 0.70.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27907 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/Manifest1
-rw-r--r--x11-libs/vte/vte-0.70.1.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index f1dfa400a49e..2ea547593f3d 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -3,3 +3,4 @@ DIST vte-0.68.0-command-notify.patch.xz 9748 BLAKE2B de2d4c9b7f2c2b21518984f818d
DIST vte-0.68.0.tar.bz2 507598 BLAKE2B 10274d9e804f00bf071b7848633ca8de2953f4e91dc2967e33b7d6698bb304baac4f0e0431debae5a972c2c56c65efd1c5b92455a17db08cf254ddec56d3276e SHA512 785df7261b5075f166e59de7d3535b381564715ce65efd4837a130e153528691b610fc6160c00f0f17008f5f4ee94c23350d9a477b4b1d58da6ace083e5caae1
DIST vte-0.70.0-command-notify.patch.xz 9040 BLAKE2B 108dd05d00409af90b1fd3e9b5c3b0e5586ac80204cef8840fda935204cbc480fec1193e2a0a2782f98e2b094c3caebbfe61cf18631b16921df05cf3808afd22 SHA512 92123e7f5cb6ef876f2b2b108dbef59bce212efebd64cd790d49d9ee3215344acd848eec5d326fe2c3bd236846ed3b896148024390093491b2f6e2f7c46e2bd1
DIST vte-0.70.0.tar.bz2 499283 BLAKE2B 694cf4dfee334e9b54bb8e47f862167acbb8ffc7ac8e81889acd4786449cb45944a87a5adaa036f46458c350ca2119bb356e90dfa71f03638c9c2b14d2ccb877 SHA512 362b71296ae39a16b55402f524a39b063f66ae237e6e161ccc89ca2bb1f2a5c43f4d706d9f3bfae12a99fdb81c4e70408c7f3eca2c01316950b0a3a1a1d79423
+DIST vte-0.70.1.tar.bz2 502044 BLAKE2B 0a9ce43c1863e823fcd073fd30fb6b2cb39e9168e850796fe12be2b9bdfc0b24ceea974b4c94bcdd10f2225613990e0e079194380241b7e625cb6dc4309a7476 SHA512 88de629b382eca8a42199b2ba9b248e231817e1de7183417aed150bcf61530084f7177d73dee9aab25fe4c3ab80d795b5fdcae336687560d3b582bd04181353d
diff --git a/x11-libs/vte/vte-0.70.1.ebuild b/x11-libs/vte/vte-0.70.1.ebuild
new file mode 100644
index 000000000000..49b766e1be02
--- /dev/null
+++ b/x11-libs/vte/vte-0.70.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org meson python-any-r1 vala xdg
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE https://gitlab.gnome.org/GNOME/vte"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="+crypt debug gtk-doc +icu +introspection systemd +vala vanilla"
+KEYWORDS="~amd64"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-0.70.0-command-notify.patch.xz )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.22:3[introspection?]
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.52:2
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ icu? ( dev-libs/icu:= )
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21:=
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ x11-libs/pango[introspection?]
+"
+RDEPEND="${DEPEND}
+ ~gui-libs/vte-common-${PV}[systemd?]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.66.2-musl-W_EXITCODE.patch
+
+ if ! use vanilla; then
+ # Part of https://src.fedoraproject.org/rpms/vte291/raw/f37/f/vte291-cntnr-precmd-preexec-scroll.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${PN}-0.70.0-command-notify.patch
+ fi
+
+ # -Ddebugg option enables various debug support via VTE_DEBUG, but also ggdb3; strip the latter
+ sed -e '/ggdb3/d' -i meson.build || die
+ sed -i 's/vte_gettext_domain = vte_api_name/vte_gettext_domain = vte_gtk3_api_name/' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=true
+ $(meson_use debug debugg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=true
+ $(meson_use crypt gnutls)
+ -Dgtk3=true
+ -Dgtk4=false
+ $(meson_use icu)
+ $(meson_use systemd _systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_install # not meson_src_install because this would include einstalldocs, which would result in file collisions with gui-libs/vte
+ # Remove files that are provided by gui-libs/vte-common
+ rm "${ED}"/usr/libexec/vte-urlencode-cwd || die
+ rm "${ED}"/etc/profile.d/vte.sh || die
+ rm "${ED}"/etc/profile.d/vte.csh || die
+ if use systemd; then
+ rm "${ED}"/usr/lib/systemd/user/vte-spawn-.scope.d/defaults.conf || die
+ fi
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/vte-${SLOT} "${ED}"/usr/share/gtk-doc/vte-${SLOT}-gtk3 || die
+ fi
+}