summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild')
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild187
1 files changed, 187 insertions, 0 deletions
diff --git a/x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild
new file mode 100644
index 000000000000..0fc560405479
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.8.12.1-r1.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic multilib versionator
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="http://wxwidgets.org/"
+
+BASE_PV="$(get_version_component_range 1-3)"
+BASE_P="${PN}-${BASE_PV}"
+
+# we use the wxPython tarballs because they include the full wxGTK sources and
+# docs, and are released more frequently than wxGTK.
+SRC_URI="mirror://sourceforge/wxpython/wxPython-src-${PV}.tar.bz2"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+X aqua doc debug gnome gstreamer odbc opengl pch sdl tiff"
+
+SLOT="2.8"
+
+RDEPEND="
+ dev-libs/expat
+ odbc? ( dev-db/unixODBC )
+ sdl? ( media-libs/libsdl )
+ X? (
+ dev-libs/glib:2
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/gtk+:2
+ x11-libs/libSM
+ x11-libs/libXinerama
+ x11-libs/libXxf86vm
+ x11-libs/pango[X]
+ gnome? ( gnome-base/libgnomeprintui:2.2 )
+ gstreamer? (
+ gnome-base/gconf:2
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ opengl? ( virtual/opengl )
+ tiff? ( media-libs/tiff:0 )
+ )
+ aqua? (
+ >=x11-libs/gtk+-2.4[aqua=]
+ virtual/jpeg
+ tiff? ( media-libs/tiff:0 )
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ opengl? ( virtual/glu )
+ X? (
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ x11-proto/xf86vidmodeproto
+ )"
+
+PDEPEND=">=app-eselect/eselect-wxwidgets-0.7"
+
+LICENSE="wxWinLL-3
+ GPL-2
+ odbc? ( LGPL-2 )
+ doc? ( wxWinFDL-3 )"
+
+S="${WORKDIR}/wxPython-src-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.8.11-unicode-odbc.patch
+ epatch "${FILESDIR}"/${PN}-2.8.11-collision.patch
+ epatch "${FILESDIR}"/${PN}-2.8.7-mmedia.patch # Bug #174874
+ epatch "${FILESDIR}"/${PN}-2.8.10.1-odbc-defines.patch # Bug #310923
+
+ # x32 https://bugs.gentoo.org/421851
+ sed -i -e "/wx_cv_std_libpath=/s:=.*:=$(get_libdir):" configure || die
+
+ # prefix https://bugs.gentoo.org/394123
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" \
+ -e '/SEARCH_INCLUDE="\\/,/"/cSEARCH_INCLUDE="'${EPREFIX}'/usr/include"' \
+ configure || die
+
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+
+ append-flags -fno-strict-aliasing
+
+ # X independent options
+ myconf="--enable-compat26
+ --enable-shared
+ --enable-unicode
+ --with-regex=builtin
+ --with-zlib=sys
+ --with-expat=sys
+ $(use_enable debug)
+ $(use_enable pch precomp-headers)
+ $(use_with odbc odbc sys)
+ $(use_with sdl)
+ $(use_with tiff libtiff sys)"
+
+ # wxGTK options
+ # --enable-graphics_ctx - needed for webkit, editra
+ # --without-gnomevfs - bug #203389
+ use X && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ $(use_enable gstreamer mediactrl)
+ $(use_enable opengl)
+ $(use_with opengl)
+ $(use_with gnome gnomeprint)
+ --without-gnomevfs"
+
+ use aqua && \
+ myconf="${myconf}
+ --enable-graphics_ctx
+ --enable-gui
+ --with-libpng=sys
+ --with-libxpm=sys
+ --with-libjpeg=sys
+ --with-mac
+ --with-opengl"
+ # cocoa toolkit seems to be broken
+
+ # wxBase options
+ if use !X && use !aqua ; then
+ myconf="${myconf}
+ --disable-gui"
+ fi
+
+ mkdir "${S}"/wxgtk_build
+ cd "${S}"/wxgtk_build
+
+ ECONF_SOURCE="${S}" econf ${myconf}
+}
+
+src_compile() {
+ cd "${S}"/wxgtk_build
+
+ emake
+
+ if [[ -d contrib/src ]]; then
+ cd contrib/src
+ emake
+ fi
+}
+
+src_install() {
+ cd "${S}"/wxgtk_build
+
+ emake DESTDIR="${D}" install
+
+ if [[ -d contrib/src ]]; then
+ cd contrib/src
+ emake DESTDIR="${D}" install
+ fi
+
+ cd "${S}"/docs
+ dodoc changes.txt readme.txt todo30.txt
+ newdoc base/readme.txt base_readme.txt
+ newdoc gtk/readme.txt gtk_readme.txt
+
+ if use doc; then
+ dohtml -r "${S}"/docs/html/*
+ fi
+
+ # Stray windows locale file, causes collisions
+ local wxmsw="${ED}usr/share/locale/it/LC_MESSAGES/wxmsw.mo"
+ [[ -e ${wxmsw} ]] && rm "${wxmsw}"
+}
+
+pkg_postinst() {
+ has_version app-eselect/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
+
+pkg_postrm() {
+ has_version app-eselect/eselect-wxwidgets \
+ && eselect wxwidgets update
+}