summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2022-06-11 22:54:46 -0400
committerSam James <sam@gentoo.org>2022-10-13 00:04:47 +0100
commit356de470bb57844ff912a1779b2a940162808c42 (patch)
treee0e12a13d3a24892c44f26b917ea97a1ee4b8b63 /x11-libs/xapp/xapp-2.2.15.ebuild
parentgames-strategy/0ad: Drop the old version alpha25b (diff)
downloadgentoo-356de470bb57844ff912a1779b2a940162808c42.tar.gz
gentoo-356de470bb57844ff912a1779b2a940162808c42.tar.bz2
gentoo-356de470bb57844ff912a1779b2a940162808c42.zip
x11-libs/xapp: 2.2.15 version bump
Bug: https://bugs.gentoo.org/863197 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/xapp/xapp-2.2.15.ebuild')
-rw-r--r--x11-libs/xapp/xapp-2.2.15.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/x11-libs/xapp/xapp-2.2.15.ebuild b/x11-libs/xapp/xapp-2.2.15.ebuild
new file mode 100644
index 000000000000..047df7917d17
--- /dev/null
+++ b/x11-libs/xapp/xapp-2.2.15.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2-utils vala meson python-r1 xdg-utils
+
+DESCRIPTION="Cross-desktop libraries and common resources"
+HOMEPAGE="https://github.com/linuxmint/xapp/"
+LICENSE="GPL-3"
+
+SRC_URI="https://github.com/linuxmint/xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+SLOT="0"
+IUSE="gtk-doc introspection static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.44.0:2
+ dev-libs/gobject-introspection:0=
+ dev-libs/libdbusmenu[gtk3]
+ gnome-base/libgnomekbd
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22.0:2[introspection?]
+ >=x11-libs/gtk+-3.16.0:3[introspection?]
+ x11-libs/libxkbfile
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ sys-devel/gettext
+
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_prepare() {
+ vala_src_prepare
+ default
+
+ # don't install distro specific tools
+ sed -i "/subdir('scripts')/d" meson.build || die
+
+ # Fix meson helpers
+ python_setup
+ python_fix_shebang meson-scripts
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dpy-overrides-dir="/pygobject"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # copy pygobject files to each active python target
+ # work-around for "py-overrides-dir" only supporting a single target
+ install_pygobject_override() {
+ PYTHON_GI_OVERRIDESDIR=$("${EPYTHON}" -c 'import gi;print(gi._overridesdir)' || die)
+ einfo "gobject overrides directory: ${PYTHON_GI_OVERRIDESDIR}"
+ mkdir -p "${D}/${PYTHON_GI_OVERRIDESDIR}/" || die
+ cp -r "${D}"/pygobject/* "${D}/${PYTHON_GI_OVERRIDESDIR}/" || die
+ python_optimize "${D}/${PYTHON_GI_OVERRIDESDIR}/"
+ }
+ python_foreach_impl install_pygobject_override
+ rm -r "${D}/pygobject" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}