summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-08-15 15:59:40 -0400
committerMatt Turner <mattst88@gentoo.org>2020-08-16 17:08:56 -0700
commitbc26ba9906aa49e18d33d4a698c1743471d3c26b (patch)
tree8305786edc9a14a2b58e6f780f22611ab653be17 /x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild
parentx11-libs/xcb-util: EAPI 7 (diff)
downloadgentoo-bc26ba9906aa49e18d33d4a698c1743471d3c26b.tar.gz
gentoo-bc26ba9906aa49e18d33d4a698c1743471d3c26b.tar.bz2
gentoo-bc26ba9906aa49e18d33d4a698c1743471d3c26b.zip
x11-libs/xcb-util-cursor: EAPI 7
Drop the SRC_URI definitions since the eclass automates it. Drop the git eclass variables since there is no live ebuild. Drop the doc USE flag since it has no effect. Drop the test flag since there are no tests. Move the gperf dependency to BDEPEND so it is natively executable. Rebuild on libxcb slot changes like every other xcb-util package. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild')
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild
new file mode 100644
index 000000000000..c992d55d7ccc
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3:=[${MULTILIB_USEDEP}]
+ x11-base/xorg-proto"
+BDEPEND=">=dev-util/gperf-3.0.1"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)