summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-05-21 21:09:20 +0200
committerMatt Turner <mattst88@gentoo.org>2018-05-21 18:05:12 -0700
commit7b45bc97a41329b490637c44bcff4921244abaec (patch)
tree4f2a892729525c15b48d27f1769de234f93d0e48 /x11-libs/xcb-util-wm/xcb-util-wm-0.4.1-r2.ebuild
parentx11-libs/xcb-util-renderutil: Drop x11-proto/xproto from dependencies. (diff)
downloadgentoo-7b45bc97a41329b490637c44bcff4921244abaec.tar.gz
gentoo-7b45bc97a41329b490637c44bcff4921244abaec.tar.bz2
gentoo-7b45bc97a41329b490637c44bcff4921244abaec.zip
x11-libs/xcb-util-wm: Drop x11-proto/xproto from dependencies.
Diffstat (limited to 'x11-libs/xcb-util-wm/xcb-util-wm-0.4.1-r2.ebuild')
-rw-r--r--x11-libs/xcb-util-wm/xcb-util-wm-0.4.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-wm/xcb-util-wm-0.4.1-r2.ebuild b/x11-libs/xcb-util-wm/xcb-util-wm-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..c5ea04a317a2
--- /dev/null
+++ b/x11-libs/xcb-util-wm/xcb-util-wm-0.4.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=https://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/xcb/util-wm.git"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+ xorg-2_src_configure
+}