summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-19 19:25:40 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-19 23:51:12 +0000
commit7b53ff123aa3db09df84d7a277fcae9d1d95e0d1 (patch)
tree7acdf39e3d3b668fd1c09ef39f1714f123f5873c /x11-libs/xpa/xpa-2.1.18.ebuild
parentsci-astronomy/predict: fix linking with ncurses (diff)
downloadgentoo-7b53ff123aa3db09df84d7a277fcae9d1d95e0d1.tar.gz
gentoo-7b53ff123aa3db09df84d7a277fcae9d1d95e0d1.tar.bz2
gentoo-7b53ff123aa3db09df84d7a277fcae9d1d95e0d1.zip
x11-libs/xpa: version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'x11-libs/xpa/xpa-2.1.18.ebuild')
-rw-r--r--x11-libs/xpa/xpa-2.1.18.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-libs/xpa/xpa-2.1.18.ebuild b/x11-libs/xpa/xpa-2.1.18.ebuild
new file mode 100644
index 000000000000..66d5897fbee1
--- /dev/null
+++ b/x11-libs/xpa/xpa-2.1.18.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="Messaging system providing communication between programs"
+HOMEPAGE="https://github.com/ericmandel/xpa"
+SRC_URI="https://github.com/ericmandel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ x11-libs/libXt:0"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.1.18-makefile.patch )
+
+src_prepare() {
+ default
+ sed -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" \
+ -i mklib || die
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-threaded-xpans \
+ --with-x \
+ --with-tcl \
+ --with-threads
+}
+
+src_compile() {
+ emake shlib tclxpa
+}
+
+src_install () {
+ dodir /usr/$(get_libdir)
+ emake INSTALL_ROOT="${D}" install
+ insinto /usr/$(get_libdir)/tclxpa
+ doins pkgIndex.tcl
+ mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
+ "${ED}"/usr/$(get_libdir)/tclxpa/ || die
+ dodoc README
+ use doc && dodoc doc/*.pdf && dodoc doc/*.html
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+}