summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2018-03-08 10:22:02 +0300
committerMaxim Koltsov <maksbotan@gentoo.org>2018-03-08 10:22:02 +0300
commit3c25eb2147f4ea84a1bd9e608b6d61e6ca9f4e87 (patch)
treed932a7dcaebd69be9b851c9eb093f05cc7fa47ec /x11-libs/xpyb
parentdev-ruby/minitest-bonus-assertions: cleanup (diff)
downloadgentoo-3c25eb2147f4ea84a1bd9e608b6d61e6ca9f4e87.tar.gz
gentoo-3c25eb2147f4ea84a1bd9e608b6d61e6ca9f4e87.tar.bz2
gentoo-3c25eb2147f4ea84a1bd9e608b6d61e6ca9f4e87.zip
x11-libs/xpyb: patch for xcb-proto-1.13
Bug: https://bugs.gentoo.org/649876 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-libs/xpyb')
-rw-r--r--x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.13.patch13
-rw-r--r--x11-libs/xpyb/xpyb-1.3.1-r4.ebuild50
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.13.patch b/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.13.patch
new file mode 100644
index 000000000000..9cb901c9727a
--- /dev/null
+++ b/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.13.patch
@@ -0,0 +1,13 @@
+diff -ur xpyb-1.3.1/src/py_client.py xpyb-1.3.1/src/py_client.py
+--- xpyb-1.3.1/src/py_client.py 2012-03-24 01:24:40.000000000 +0400
++++ xpyb-1.3.1/src/py_client.py 2018-03-08 10:13:48.342758718 +0300
+@@ -585,7 +585,8 @@
+ 'union' : py_union,
+ 'request' : py_request,
+ 'event' : py_event,
+- 'error' : py_error
++ 'error' : py_error,
++ 'eventstruct' : lambda *a, **k: None
+ }
+
+ # Boilerplate below this point
diff --git a/x11-libs/xpyb/xpyb-1.3.1-r4.ebuild b/x11-libs/xpyb/xpyb-1.3.1-r4.ebuild
new file mode 100644
index 000000000000..1e7d210bc6ae
--- /dev/null
+++ b/x11-libs/xpyb/xpyb-1.3.1-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=1
+
+inherit flag-o-matic xorg-2 python-r1
+
+#EGIT_REPO_URI="https://anongit.freedesktop.org/git/xcb/xpyb.git"
+SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
+DESCRIPTION="XCB-based Python bindings for the X Window System"
+HOMEPAGE="https://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="selinux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=x11-libs/libxcb-1.7
+ >=x11-proto/xcb-proto-1.7.1[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-python.patch
+ "${FILESDIR}"/${PN}-1.3.1-xcbproto-1.9.patch
+ "${FILESDIR}"/${PN}-1.3.1-xcbproto-1.13.patch
+)
+DOCS=( NEWS README )
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable selinux)
+ )
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+ python_foreach_impl xorg-2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl xorg-2_src_compile
+}
+
+src_install() {
+ python_foreach_impl xorg-2_src_install
+}