summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2018-10-04 18:06:38 +0900
committerNaohiro Aota <naota@gentoo.org>2018-10-04 18:10:03 +0900
commit03a85ffcdd94ca337e2044564ef640037f225a2f (patch)
treed22c32e934f140912a293048e212c7459523a2e6 /x11-libs
parentdev-libs/yajl: Drop 2.1.0 (r0), de-stabilising hppa (diff)
downloadgentoo-03a85ffcdd94ca337e2044564ef640037f225a2f.tar.gz
gentoo-03a85ffcdd94ca337e2044564ef640037f225a2f.tar.bz2
gentoo-03a85ffcdd94ca337e2044564ef640037f225a2f.zip
x11-libs/libgxim: add missing dependency
Add missing dependency: dev-util/glib-utils and x11-libs/libX11. Also, replace ltprune with find. Closes: https://bugs.gentoo.org/667470 Signed-off-by: Naohiro Aota <naota@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libgxim/libgxim-0.5.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-libs/libgxim/libgxim-0.5.0.ebuild b/x11-libs/libgxim/libgxim-0.5.0.ebuild
index 8d4bb4e5405b..bc716195e9fe 100644
--- a/x11-libs/libgxim/libgxim-0.5.0.ebuild
+++ b/x11-libs/libgxim/libgxim-0.5.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-inherit autotools ltprune ruby-single
+inherit autotools ruby-single
DESCRIPTION="GObject-based XIM protocol library"
HOMEPAGE="https://tagoh.bitbucket.io/libgxim"
@@ -19,9 +19,11 @@ RDEPEND="dev-libs/dbus-glib
dev-libs/glib:2
sys-apps/dbus
virtual/libintl
- x11-libs/gtk+:2"
+ x11-libs/gtk+:2
+ x11-libs/libX11"
DEPEND="${RDEPEND}
${RUBY_DEPS}
+ dev-util/glib-utils
dev-util/intltool
sys-devel/autoconf-archive
sys-devel/gettext
@@ -57,5 +59,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -delete || die
}