summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-12-19 08:13:05 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2017-12-19 08:38:23 +0100
commit12c0e2bdde7ff1d917fb72820256c8ca42b6c875 (patch)
tree4cdb6bea4e1a502112c556e887a08165d3adb679 /x11-libs
parentsci-libs/hdf5: Add back hl configuration options. (diff)
downloadgentoo-12c0e2bdde7ff1d917fb72820256c8ca42b6c875.tar.gz
gentoo-12c0e2bdde7ff1d917fb72820256c8ca42b6c875.tar.bz2
gentoo-12c0e2bdde7ff1d917fb72820256c8ca42b6c875.zip
x11-libs/pango: version bump 1.40.12 → 1.40.14, performance updates
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.40.14.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index ea9161d11dfa..aa65db433e0b 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -1,3 +1,4 @@
DIST pango-1.40.12.tar.xz 856228 BLAKE2B c6fe562f64ac7b641b5b8519f831b999418ab06c1686ac07aa08b587bfba761a834e698f033bdb79666ea6ddd6c1f672ce968897c7594e4467c5b6dee644877e SHA512 772792edac9ab5b6f76617cd3512432ca6b9af1d5ee6bfb87d0b60293f560026d479df059da66f53ba567f916a275e82f1cdd17ca75bb0da7ae2a79d4a75ed6d
+DIST pango-1.40.14.tar.xz 858388 BLAKE2B 1afcff08c38aa59ec57cdf43aa503e70a8c03b7d59c730060c9e3537f78ffe9a63e3aa1cb74ce9ce8d72541b5a5be8becb951f665f4663b108114686c41452c8 SHA512 35ba7bc8be3992f206ccc2cc5aca0b94e2a3832f887fc9c45b0e29fddcb9051ce05a74377de0ca4ff95a87983b15688fa5d379d592faf87aa8eaca25ac18b7ea
DIST pango-1.40.3.tar.xz 1061044 BLAKE2B 79acd03144b58a3c160888cf4e3638faaf622cfcb406ddcd6a17907bddb7b3c6bf8c4a8ffbedb095664b7d19daa6837239e317d03e9a485f01b832227d1c3b7d SHA512 ff82395e8487624dffe212975b72b3383dcebb197a8675c8b409665e3e2e30fc23d9a6c25c3129a115adb7182b2a71a49550dbe881eb7ee9bbc572de6ba18d27
DIST pango-1.40.6.tar.xz 832040 BLAKE2B af5597194e02c21b8e3ceb6097482dd23a9eaf74b5ca618cc39a1f44317cdab6ecef3125f5952a7b9fd306e67301de4503efbf082b3c8c172615c523e71d6a55 SHA512 d916b364a77de3e68779e6d841d95bca456daf89405b92eaf51dceef093a9761cbb6c48f4c2971dec47c0bbdb645a3f3f4fb9af425274bf1d1822b278575e1f7
diff --git a/x11-libs/pango/pango-1.40.14.ebuild b/x11-libs/pango/pango-1.40.14.ebuild
new file mode 100644
index 000000000000..0b59c658a54d
--- /dev/null
+++ b/x11-libs/pango/pango-1.40.14.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2+ FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="X +introspection test"
+
+RDEPEND="
+ >=media-libs/harfbuzz-1.2.3:=[glib(+),truetype(+),${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.10.92:1.0=[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.14-r4:=[X?,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( media-fonts/cantarell )
+ X? ( >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
+ !<=sys-devel/autoconf-2.63:2.5
+"
+
+multilib_src_configure() {
+ tc-export CXX
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --with-cairo \
+ $(multilib_native_use_enable introspection) \
+ $(use_with X xft) \
+ "$(usex X --x-includes="${EPREFIX}/usr/include" "")" \
+ "$(usex X --x-libraries="${EPREFIX}/usr/$(get_libdir)" "")"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}