summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-02 22:29:37 -0500
committerMatt Turner <mattst88@gentoo.org>2024-03-02 23:24:12 -0500
commit1b159c7e38242b2c221fb8b10f3833ebdf0a34ef (patch)
treee3eb62b95a1a7e4cf6a788c0420a10dd63992ba7 /x11-libs
parentx11-libs/libXaw3d: Version bump to 1.6.6 (diff)
downloadgentoo-1b159c7e38242b2c221fb8b10f3833ebdf0a34ef.tar.gz
gentoo-1b159c7e38242b2c221fb8b10f3833ebdf0a34ef.tar.bz2
gentoo-1b159c7e38242b2c221fb8b10f3833ebdf0a34ef.zip
x11-libs/libXdmcp: Version bump to 1.1.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXdmcp/Manifest1
-rw-r--r--x11-libs/libXdmcp/libXdmcp-1.1.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXdmcp/Manifest b/x11-libs/libXdmcp/Manifest
index 83cc9235449b..f4605f25009d 100644
--- a/x11-libs/libXdmcp/Manifest
+++ b/x11-libs/libXdmcp/Manifest
@@ -1 +1,2 @@
DIST libXdmcp-1.1.4.tar.xz 295184 BLAKE2B 9360125a98bb38175be488a815eeb559e432dc2d2f60545b11dc315777de27ad68d34df7e73b0b7c14e58eaa8d92bf5a4055184df95df08cfb39dd896acc9f02 SHA512 83b384d43bfb034c395f83f97d1c6e73aa3d5faa8f8756b08e697c0b9c3c87189651b51e8213fbd1f5f9cbc2d8136cbf143627481744345d78cfe0ff2ad074a9
+DIST libXdmcp-1.1.5.tar.xz 297596 BLAKE2B 81d02e510d07083550a630867bbf60f4f6fd0044433c99af504d791211f828d8109763ae0f01bb1b690a13f099f75a21a7c3bfc4aa7e2435f7327467eedd514e SHA512 d7a1d70a58b7d34ddd01a91d3ccbc086a36626b7081cfcbb150d24288c6adad612b042ba7ea63a218595afb2ee04384c0f8ba84ee3c6bd29913724b54e898d83
diff --git a/x11-libs/libXdmcp/libXdmcp-1.1.5.ebuild b/x11-libs/libXdmcp/libXdmcp-1.1.5.ebuild
new file mode 100644
index 000000000000..eafcd84874c9
--- /dev/null
+++ b/x11-libs/libXdmcp/libXdmcp-1.1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org X Display Manager Control Protocol library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ elibc_glibc? (
+ || ( >=sys-libs/glibc-2.36 dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ )
+ !elibc_glibc? (
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}