summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-08 18:34:40 -0400
committerConrad Kostecki <conikost@gentoo.org>2022-05-14 00:49:36 +0200
commit25c9a358aa36da91f16fc8b2ab2f0031cb68df33 (patch)
tree9e72a7e95409fd12151f89e40ddd5668b1e243b2 /x11-libs
parentwww-apache/passenger: remove unused patch (diff)
downloadgentoo-25c9a358aa36da91f16fc8b2ab2f0031cb68df33.tar.gz
gentoo-25c9a358aa36da91f16fc8b2ab2f0031cb68df33.tar.bz2
gentoo-25c9a358aa36da91f16fc8b2ab2f0031cb68df33.zip
x11-libs/libva-intel-media-driver: Version bump to 22.4.1
Signed-off-by: Matt Turner <mattst88@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/25420 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva-intel-media-driver/Manifest1
-rw-r--r--x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.4.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-libs/libva-intel-media-driver/Manifest b/x11-libs/libva-intel-media-driver/Manifest
index 7198362d4022..a73cae356cc1 100644
--- a/x11-libs/libva-intel-media-driver/Manifest
+++ b/x11-libs/libva-intel-media-driver/Manifest
@@ -1,2 +1,3 @@
DIST intel-media-22.1.0.tar.gz 26188730 BLAKE2B 7ade4b25d2fe50ed6c3498c37f0fb39ecf7241ba21485c423a4a8769628b78d8134471639aad12bcac79a7d107682e36cb5954227528601eb5253be5ce00acac SHA512 dd444608fd15fc7f05a0d2c9e6e2c8be3a588a1253ac014c045c207d5d59c9d172c89d248e94688078097a224f57025c11e86b9392271cd111bb9dce6d07617e
DIST intel-media-22.3.1.tar.gz 27302226 BLAKE2B 24ac80adcd9a72f9e9b7db4b878715233835f2b69a25d1029538fb87da1fa49ed3c0606478a8b24e198f0c366003ff315e31972c7576e9ff2ecd8419e12ab150 SHA512 286f974a11546f8541429230330c5bd514c5eb372d3278461a132fb236f19908aa544a44010e52981bb942573ab6c2047c8c03471517182e2daf2da87b0eb74f
+DIST intel-media-22.4.1.tar.gz 27407593 BLAKE2B eed738064b6febc17e93f195f81f71be55cb539f0bac1a90b0a60695b89ed2eb8deac5da3a646bd178396ace8e68c35a8e58fbebd74e6298aea6c1bd505fd482 SHA512 7615c76d501f9fa127da8465c4f5ecf8067b0374e14ee699b874ec7b4dfc131630901e2ec4d85e420b13c33bb1431938adefb60add7e1abe7e7351bec5e6322c
diff --git a/x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.4.1.ebuild b/x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.4.1.ebuild
new file mode 100644
index 000000000000..9a49528f5647
--- /dev/null
+++ b/x11-libs/libva-intel-media-driver/libva-intel-media-driver-22.4.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/media-driver"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ MY_PV="${PV%_pre}"
+ SRC_URI="https://github.com/intel/media-driver/archive/intel-media-${MY_PV}.tar.gz"
+ S="${WORKDIR}/media-driver-intel-media-${MY_PV}"
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~amd64"
+ fi
+fi
+
+DESCRIPTION="Intel Media Driver for VAAPI (iHD)"
+HOMEPAGE="https://github.com/intel/media-driver"
+
+LICENSE="MIT BSD redistributable? ( no-source-code )"
+SLOT="0"
+IUSE="+redistributable test X"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=media-libs/gmmlib-22.0.0:=
+ >=x11-libs/libva-2.14.0[X?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.0_x11_optional.patch
+ "${FILESDIR}"/${PN}-21.4.2-Remove-unwanted-CFLAGS.patch
+ "${FILESDIR}"/${PN}-20.4.5_testing_in_src_test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEDIA_BUILD_FATAL_WARNINGS=OFF
+ -DMEDIA_RUN_TEST_SUITE=$(usex test)
+ -DBUILD_TYPE=Release
+ -DPLATFORM=linux
+ -DUSE_X11=$(usex X)
+ -DENABLE_NONFREE_KERNELS=$(usex redistributable)
+ -DLATEST_CPP_NEEDED=ON # Seems to be the best option for now
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}