summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-19 22:41:26 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-19 22:50:07 -0500
commit2e68f79b72721f9c47aa0e8c4c7bfcf6869b1ebd (patch)
tree7faef3b82d6ffee5f171278e9c0508ad5f59ab96 /x11-libs
parentdev-util/trace-cmd: Version bump 3.1.5 (diff)
downloadgentoo-2e68f79b72721f9c47aa0e8c4c7bfcf6869b1ebd.tar.gz
gentoo-2e68f79b72721f9c47aa0e8c4c7bfcf6869b1ebd.tar.bz2
gentoo-2e68f79b72721f9c47aa0e8c4c7bfcf6869b1ebd.zip
x11-libs/libSM: Version bump to 1.2.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libSM/Manifest1
-rw-r--r--x11-libs/libSM/libSM-1.2.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/libSM/Manifest b/x11-libs/libSM/Manifest
index c85bffd502d9..e54c49123fd1 100644
--- a/x11-libs/libSM/Manifest
+++ b/x11-libs/libSM/Manifest
@@ -1 +1,2 @@
DIST libSM-1.2.3.tar.bz2 362595 BLAKE2B 20b7327cd16e066bd2a81eae60f52cab7499dd92d65786d0e5726faa64c2055376749562ff2158777f83711e1517b90b2dc94670892b787889b3950c0a975b68 SHA512 74c42e27029db78475e62025b4711dbac5e22d2f8e8a24be98a1c31b03c0fc4afe859928f851800ea0b76854f12147900dc4f27bbfd3d8ea45daaaf24b70a903
+DIST libSM-1.2.4.tar.xz 306944 BLAKE2B c1944cd8e25389cffc18e9f6e46e3543381a2d74036cff2c24f063c1defca001c94055ef278dc468123b1f60f145df5daf34bcec39875ad918b664a3c279777a SHA512 7f1d41b7b6c5dd456c49ccad7740c3ba9791a2793fa50fd94814a4164ce2e20c4a0a0ad42a87708e494ed5c23f611be6d3ccd9ef1e9add6d46ac545e2b0f6f86
diff --git a/x11-libs/libSM/libSM-1.2.4.ebuild b/x11-libs/libSM/libSM-1.2.4.ebuild
new file mode 100644
index 000000000000..ce89e40f714d
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Session Management library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+uuid"
+
+RDEPEND="
+ >=x11-libs/libICE-1.1.0[${MULTILIB_USEDEP}]
+ uuid? (
+ elibc_Darwin? ( sys-libs/native-uuid )
+ !elibc_SunOS? ( !elibc_Darwin? (
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ ) )
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+
+src_configure() {
+ local withuuid=$(use_with uuid libuuid)
+
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+
+ if use uuid ; then
+ case ${CHOST} in
+ *-solaris*|*-darwin*)
+ if [[ ! -d ${EROOT}/usr/include/uuid ]] &&
+ [[ -d ${ROOT}/usr/include/uuid ]]
+ then
+ # Solaris and Darwin have uuid provided by the host
+ # system. Since util-linux's version is based on this
+ # version, and on Darwin actually breaks host headers when
+ # installed, we can "pretend" for libSM we have libuuid
+ # installed, while in fact we don't
+ withuuid="--without-libuuid"
+ export HAVE_LIBUUID=yes
+ export LIBUUID_CFLAGS="-I${ROOT}/usr/include/uuid"
+ # Darwin has uuid in libSystem
+ [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+ fi
+ ;;
+ esac
+ fi
+
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ ${withuuid}
+ --without-fop
+ )
+ xorg-3_src_configure
+}