summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-14 12:11:09 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-14 12:15:09 -0700
commit326b958fb92db736428e3927979f42583f4cf233 (patch)
tree9064e1efe47458186cb249043bbccd0a35590233 /x11-libs
parentsys-devel/bison: bump to v3.4.2 (diff)
downloadgentoo-326b958fb92db736428e3927979f42583f4cf233.tar.gz
gentoo-326b958fb92db736428e3927979f42583f4cf233.tar.bz2
gentoo-326b958fb92db736428e3927979f42583f4cf233.zip
x11-libs/libXfont2: Port to EAPI 7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXfont2/libXfont2-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-libs/libXfont2/libXfont2-9999.ebuild b/x11-libs/libXfont2/libXfont2-9999.ebuild
index 9463d5e13105..cfd74911baa4 100644
--- a/x11-libs/libXfont2/libXfont2-9999.ebuild
+++ b/x11-libs/libXfont2/libXfont2-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
XORG_PACKAGE_NAME=libxfont
XORG_DOC=doc
-inherit xorg-2
+inherit xorg-3
DESCRIPTION="X.Org Xfont library"
@@ -15,12 +15,13 @@ IUSE="bzip2 ipv6 truetype"
RDEPEND="sys-libs/zlib
x11-base/xorg-proto
x11-libs/libfontenc
- x11-libs/xtrans
bzip2? ( app-arch/bzip2 )
truetype? ( >=media-libs/freetype-2 )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
-src_configure() {
+pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
$(use_enable doc devel-docs)
@@ -29,5 +30,4 @@ src_configure() {
$(use_enable truetype freetype)
--without-fop
)
- xorg-2_src_configure
}