summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-17 16:33:54 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-17 16:34:56 -0400
commit414462335909ac1cdfa276058238304228c7b129 (patch)
treec95866ffd775b7a74402235b89ffe0d62fb3e811 /x11-libs
parentnet-dns/pdns: add 4.7.4 (diff)
downloadgentoo-414462335909ac1cdfa276058238304228c7b129.tar.gz
gentoo-414462335909ac1cdfa276058238304228c7b129.tar.bz2
gentoo-414462335909ac1cdfa276058238304228c7b129.zip
x11-libs/libXpm: Version bump to 3.5.16
Bug: https://bugs.gentoo.org/891209 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXpm/Manifest1
-rw-r--r--x11-libs/libXpm/libXpm-3.5.16.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/libXpm/Manifest b/x11-libs/libXpm/Manifest
index 923605725ed2..6d4e14caeb84 100644
--- a/x11-libs/libXpm/Manifest
+++ b/x11-libs/libXpm/Manifest
@@ -1 +1,2 @@
DIST libXpm-3.5.14.tar.xz 392624 BLAKE2B fe87d246222717b1120647c59fd4c466914fca2debff20f33bfe49b0c58643a6d122e17e0e092c1570b28c945887cbb94e27989b6dbeadeae503a1811b7bbf09 SHA512 c3fe554453068a6b188d3cad2cb3648e84b7f1909aea8f213daadce3d444b34361c3b2edce14a4fd481f97e4dc45c3125e2483ff4f44b3390a75829ed2782e4b
+DIST libXpm-3.5.16.tar.xz 469020 BLAKE2B d234b2b3e074ae424f2d01894a48f53928085cde7ede8b3ec31dc2ea9484f9b024ee0e556a648e05b7ae4ea78e44bb5838d8a354387c7aafcaa4952f0879d247 SHA512 ee564311f8c1c9c08ed1035d55c287ecf7c20c6fee09ad448acfab59f38fd1ef381d4a24b4af2b581f3033730eebc7c690918e52ba706de689d1ef11085edac2
diff --git a/x11-libs/libXpm/libXpm-3.5.16.ebuild b/x11-libs/libXpm/libXpm-3.5.16.ebuild
new file mode 100644
index 000000000000..5166bcfa0557
--- /dev/null
+++ b/x11-libs/libXpm/libXpm-3.5.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xpm library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+
+ app-arch/gzip
+ app-arch/ncompress
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-libs/glib-2.46:2 )
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ app-arch/gzip
+ app-arch/ncompress
+ )
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable test unit-tests)
+ )
+ xorg-3_src_configure
+}