summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-08-12 02:08:41 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-13 17:45:27 +0200
commit57a34b67a68b7701ba99372cb4602e735895ea6e (patch)
tree0fa0475eaa08c2861e19d43a0b6fa7baabc96bfc /x11-libs
parentdev-libs/libqtxdg: remove versions 3.3.1 and 3.4.0 (diff)
downloadgentoo-57a34b67a68b7701ba99372cb4602e735895ea6e.tar.gz
gentoo-57a34b67a68b7701ba99372cb4602e735895ea6e.tar.bz2
gentoo-57a34b67a68b7701ba99372cb4602e735895ea6e.zip
x11-libs/libfm-qt: remove versions 0.14.1 (r2) and 0.15.1 (r0)
Also remove a no longer needed patch. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfm-qt/Manifest1
-rw-r--r--x11-libs/libfm-qt/files/libfm-qt-0.14.1-phantom-desktop-files.patch109
-rw-r--r--x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild41
-rw-r--r--x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild47
4 files changed, 0 insertions, 198 deletions
diff --git a/x11-libs/libfm-qt/Manifest b/x11-libs/libfm-qt/Manifest
index 8955a00504f9..134aa06c61fe 100644
--- a/x11-libs/libfm-qt/Manifest
+++ b/x11-libs/libfm-qt/Manifest
@@ -1,2 +1 @@
-DIST libfm-qt-0.14.1.tar.xz 328192 BLAKE2B ff229256d3232eabc046da1fed3e4b4e51a09c3d1f2815fa726bad62f3fc53111e5d7f003e82e383dde4fe910584644e66613cbc1803ad0e11f7b6bdb2e30cfe SHA512 a265f6831a077ccb78a994828e6c69a22f2f6432b1f6ed6f404af41f013112870f7aee98067f2c466bec6cdfea040c10c7ce7e0f0ed977e5d266ec38e543d2a7
DIST libfm-qt-0.15.1.tar.xz 337396 BLAKE2B 619787039857f0b67245ff86f4c8de1b5305909bbf1dc07f20ab53f07a955d541853066a9011bb76d04a49006732ea23c4100e94fe3c61de77f1edbbbdef5854 SHA512 9bd3f61d830e4f7ba3e72d84e3ff1a07544f6f461d6eea7ecf2b31056020e08d47d83ef920b6e1a481a470dadfb995a6b3e3b57a13574d6abca617a84c71bdf5
diff --git a/x11-libs/libfm-qt/files/libfm-qt-0.14.1-phantom-desktop-files.patch b/x11-libs/libfm-qt/files/libfm-qt-0.14.1-phantom-desktop-files.patch
deleted file mode 100644
index b9edab299cd4..000000000000
--- a/x11-libs/libfm-qt/files/libfm-qt-0.14.1-phantom-desktop-files.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-From f944be7d2447d5c579a57fb5519ee5e2dece5871 Mon Sep 17 00:00:00 2001
-From: Tsu Jan <tsujan2000@gmail.com>
-Date: Sun, 21 Apr 2019 14:11:14 +0430
-Subject: [PATCH] Don't ignore creation-deletion sequences
-
-Fixes https://github.com/lxqt/pcmanfm-qt/issues/944
-
-Previously, if a file was in addition queue and then it came into the deletion queue, its addition and deletion were both ignored. That was wrong and could result in showing nonexistent files because addition can also happen in directory list job before being processed by file info job.
-
-Also process accumulated changes only after finishing the current info job and don't clear all deletion paths after processing them (because, logically, only those paths that can be deleted should be removed).
----
- src/core/folder.cpp | 60 +++++++++++++++++++++++----------------------
- 1 file changed, 31 insertions(+), 29 deletions(-)
-
-diff --git a/src/core/folder.cpp b/src/core/folder.cpp
-index 6c2b27d..2385a8b 100644
---- a/src/core/folder.cpp
-+++ b/src/core/folder.cpp
-@@ -228,16 +228,6 @@ void Folder::onFileInfoFinished() {
- return;
- }
-
-- // process the changes accumulated during this info job
-- if(filesystem_info_pending // means a pending change; see "onFileSystemInfoFinished()"
-- || !paths_to_update.empty() || !paths_to_add.empty() || !paths_to_del.empty()) {
-- QTimer::singleShot(0, this, &Folder::processPendingChanges);
-- }
-- // there's no pending change at the moment; let the next one be processed
-- else {
-- has_idle_update_handler = false;
-- }
--
- FileInfoList files_to_add;
- FileInfoList files_to_delete;
- std::vector<FileInfoPair> files_to_update;
-@@ -271,6 +261,16 @@ void Folder::onFileInfoFinished() {
- Q_EMIT filesChanged(files_to_update);
- }
- Q_EMIT contentChanged();
-+
-+ // process the changes accumulated during this info job
-+ if(filesystem_info_pending // means a pending change; see "onFileSystemInfoFinished()"
-+ || !paths_to_update.empty() || !paths_to_add.empty() || !paths_to_del.empty()) {
-+ QTimer::singleShot(0, this, &Folder::processPendingChanges);
-+ }
-+ // there's no pending change at the moment; let the next one be processed
-+ else {
-+ has_idle_update_handler = false;
-+ }
- }
-
- void Folder::processPendingChanges() {
-@@ -314,21 +314,24 @@ void Folder::processPendingChanges() {
- }
-
- // process deletion
-- if(!paths_to_del.empty()) {
-- FileInfoList deleted_files;
-- for(const auto &path: paths_to_del) {
-- auto name = path.baseName();
-- auto it = files_.find(name.get());
-- if(it != files_.end()) {
-- deleted_files.push_back(it->second);
-- files_.erase(it);
-- }
-+ FileInfoList deleted_files;
-+ auto path_it = paths_to_del.begin();
-+ while(path_it != paths_to_del.end()) {
-+ const auto& path = *path_it;
-+ auto name = path.baseName();
-+ auto it = files_.find(name.get());
-+ if(it != files_.end()) {
-+ deleted_files.push_back(it->second);
-+ files_.erase(it);
-+ path_it = paths_to_del.erase(path_it);
- }
-- if(!deleted_files.empty()) {
-- Q_EMIT filesRemoved(deleted_files);
-- Q_EMIT contentChanged();
-+ else {
-+ ++path_it;
- }
-- paths_to_del.clear();
-+ }
-+ if(!deleted_files.empty()) {
-+ Q_EMIT filesRemoved(deleted_files);
-+ Q_EMIT contentChanged();
- }
-
- if(pending_change_notify) {
-@@ -404,13 +407,12 @@ void Folder::eventFileDeleted(const FilePath& path) {
- bool deleted = true;
- // qDebug() << "delete " << path.baseName().get();
- // G_LOCK(lists);
-- if(std::find(paths_to_add.cbegin(), paths_to_add.cend(), path) != paths_to_add.cend()) {
-- // if the file was going to be added, just remove it from the addition queue
-- paths_to_add.erase(std::remove(paths_to_add.begin(), paths_to_add.end(), path), paths_to_add.cend());
-- }
-- else if(std::find(paths_to_del.cbegin(), paths_to_del.cend(), path) == paths_to_del.cend()) {
-+ /* WARNING: If the file is in the addition queue, we shouldn not remove it from that queue
-+ and ignore its deletion because it may have been added by the directory list job, in
-+ which case, ignoring an addition-deletion sequence would result in a nonexistent file. */
-+ if(std::find(paths_to_del.cbegin(), paths_to_del.cend(), path) == paths_to_del.cend()) {
- paths_to_del.push_back(path);
-- // the update queue should be cancelled for a file that is going to be deleted
-+ // the update queue can be cancelled for a file that is going to be deleted
- paths_to_update.erase(std::remove(paths_to_update.begin(), paths_to_update.end(), path), paths_to_update.cend());
- }
- else {
diff --git a/x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild b/x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild
deleted file mode 100644
index 57a6caf855e8..000000000000
--- a/x11-libs/libfm-qt/libfm-qt-0.14.1-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Qt port of libfm, a library providing components to build desktop file managers"
-HOMEPAGE="https://lxqt.github.io/"
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-fi
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0/5"
-
-BDEPEND="
- dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.6.0
- virtual/pkgconfig
-"
-DEPEND="
- dev-libs/glib:2
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- >=lxde-base/menu-cache-1.1.0
- media-libs/libexif:=
- x11-libs/libxcb:=
-"
-RDEPEND="${DEPEND}
- !lxqt-base/lxqt-l10n
-"
-
-PATCHES="${FILESDIR}/${PN}-0.14.1-phantom-desktop-files.patch"
diff --git a/x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild b/x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild
deleted file mode 100644
index d22a9ffd9ab0..000000000000
--- a/x11-libs/libfm-qt/libfm-qt-0.15.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg-utils
-
-DESCRIPTION="Qt Library for Building File Managers"
-HOMEPAGE="https://lxqt.github.io/"
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-fi
-
-LICENSE="BSD GPL-2+ LGPL-2.1+"
-SLOT="0/7"
-
-BDEPEND="
- dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.7.0
- virtual/pkgconfig
-"
-DEPEND="
- dev-libs/glib:2
- dev-qt/qtcore:5
- dev-qt/qtgui:5=
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- >=lxde-base/menu-cache-1.1.0:=
- media-libs/libexif
- x11-libs/libxcb
-"
-RDEPEND="${DEPEND}
- !lxqt-base/lxqt-l10n
-"
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
-}